1

Chrome and Firefox are using java plug-in 1.7.0_25, which is automatically disabled because it is not a safe version (I should install plug-in 1.7.2_45). The problem is that it doesn't matter what I do, Chrome and Firefox keep pointing to the wrong version.

How should I proceed in order to use the correct plug-in, I really need it to access many important sites.

  • Could you detail how you installed Java? – Braiam Oct 30 '13 at 0:44
  • Give a try to this and this link. Hope you would get more help from these links.. :) – Saurav Kumar Oct 30 '13 at 1:32
2
+100
  1. Remove the current Java version and all its configuration files:

    sudo apt-get purge icedtea-7-plugin
    
  2. Get the latest one from Java website here as the one in Ubuntu Repositories is 1.7.0_25.

  3. Install it using these instructions:

    • Change to the directory in which you want to install.

      cd /directory/path/name
      

    For example, to install the software in the /usr/java/ directory, Type: cd /usr/java/

    Note about root access: To install Java in a system-wide location such as /usr/local, you must login as the root user to gain the necessary permissions. If you do not have root access, install the Java in your home directory or a sub directory for which you have write permissions

    • Move the .tar.gz archive binary to the current directory. (Use sudo if you're moving to a system location.)

    • Unpack the tarball and install Java

      tar zxvf jre-7u7-linux-i586.tar.gz
      

    The Java files are installed in a directory called jre1.7.0_07 in the current directory. In this example, it is installed in the /usr/java/jre1.7.0_07 directory. Delete the .tar.gz file if you want to save disk space.

  • I had to do it 3 or 4 times .. but this worked – morcillo Oct 31 '13 at 1:43
  • 1
    nice help, but 'Unpack the tarball and install Java': how to install Java? – cwhisperer Nov 3 '15 at 9:00
  • This worked in Ubuntu/Kubuntu 16.04 LTS – code_dredd Aug 4 '16 at 19:44
1

Since licence changes by Oracle, the latest Sun/Java environment is not available in the repositories anymore.

The team of webup8.org has made a nice workaround in the own repositories. You will get autmatic updates with it! I use it on my own and always have the latest version:

[1] http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

Otherwise, have a look at the Community help for other workarounds:

[2] https://help.ubuntu.com/community/Java#Oracle_Java_7

  • I totally advocate webupd8's ppa. There are also many other convenient things in it. Here is an overview: WebUpd8 PPA Overview – mondjunge Oct 30 '13 at 14:54
0

1 - Open Terminal

2 - Copy & Paste Command:

sudo apt-get install icedtea-7-plugin

3 - Press Enter

4 - Enter Your Username

5 - Press Enter

The Java Plugin Will Now Be Installed.

In Chrome go to Settings > Show Advanced Settings > Privacy then click on

Content Settings > Plug-ins then click on Disable Individual Plug-in

Disable both IceTea-Web Plugin and Java(TM)

Restart the browser.

Chrome > Settings > Show Advanced Settings > Privacy then click on

Content Settings > Plug-ins then click on Disable Individual Plug-in

Enable only IceTea-Web Plugin

Check That The Browser Plugin Works Correctly By Going To The Java Site:

http://www.java.com/en/download/installed.jsp?detect=jre

  • Already donde that several times. It doesn't update. I also tried deleting some files in the profile folder so it will look for the other plug-ins but it still doesn't update. – morcillo Oct 27 '13 at 19:33
  • tried your edit ... it does even less now ... now it says that it could not load the icedtea web plugin – morcillo Oct 27 '13 at 19:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.