I'm setting up a new computer running Ubuntu 12.04 and am having trouble getting the scanner on my Epson Stylus SX235W All-in-one to be recognised. I would like to be able to use the 'Image Scan! For Linux' program. The device is connected via usb.

I installed the relevant .deb files from the Epson Download Center for Image Scan!, namely


and installed them in that order, but the program wouldn't load.

An internet search suggested downloading the libsane-extras package and editing the /etc/sane.d/dll.conf file so that the relevant driver was uncommented in the list, which I did but to no effect.

I tried uncommenting the following lines

epson epson2

I also tried to force libsane to use the scanner by adding the number obtained from a 'lsusb' terminal command (Bus 003 Device 012: ID 04b8:0885 Seiko Epson Corp) in this form

usb 0x04b8 0x0885

to the epson.conf file but nothing happened. Beyond this I don't really know what I'm doing so any help would be greatly appreciated.

Thanks very much.


The information at - Epson Scanner sx218 - Works Intermittently

may help. The /etc/sane.d/dll.conf and /etc/sane.d/epkowa.conf had the correct entries when the .deb packages were installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.