This seemed to help but the dash is still not searching files. It however does search folders.

Document Directory searches fine.

Download directory doesn't search correctly even though I just just added items (I did open the items because I read unity doesn't index items unless they are opened).

Things I have tried:

rm ~/.cache/software-center -R
unity --reset &

Download Directory contains:

/home/username/Downloads/Untitled Folder

Searching the dash with the keyworld "Downloads" yields: 1 folder "Downloads"

Document Directory Contains:


Searching the dash with the keyworld "Documents" yields: 1 folder "Documents":


but "tryingtosearch" is not there. Is this a file indexing issue?

If it matters I did run this code previously:

gsettings set com.canonical.Unity.Lenses disabled-scopes "['more_suggestions-amazon.scope', 'more_suggestions-u1ms.scope', 'more_suggestions-populartracks.scope', 'music-musicstore.scope', 'more_suggestions-ebay.scope', 'more_suggestions-ubuntushop.scope', 'more_suggestions-skimlinks.scope']"

and this code:

sudo apt-get remove unity-webapps*

^This messed up my desktop and I had to fix it. I don't recall what command I used to fix it but I think it was this: sudo dconf reset -f /org/compiz/

This seemed to fix it:

sudo updatedb

Should I really have to run that each time though? Obviously one could create a bash script but that is disappointing if one has to run that each time.

I have tried the solutions on this page:

  • possible duplicate of Dash search gives no result Oct 27, 2013 at 13:04
  • 2
    Not a duplicate; I have tried the solutions on that page. Also, they are running Ubuntu 11.10, and I am running Ubuntu 13.10 with the new Smart-Scopes feature.
    – horvste
    Oct 27, 2013 at 13:07
  • 1
    updatedb is automatically run once a day. You only have to run it manually when you need to update it immediately. Oct 27, 2013 at 14:06

2 Answers 2

sudo apt-get -o DPkg::options::=--force-confmiss --reinstall install unity-scopes-master-default

sudo apt-get -o DPkg::options::=--force-confmiss --reinstall install unity-scopes-runner

sudo apt-get -o DPkg::options::=--force-confmiss --reinstall install unity-scope-home

Running sudo updatedb fixed this by re-indexing unity's search engine. The search now searches anything after running sudo updatedb.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .