I'm fairly new to Linux so fancy lingo will need explaining :-)

Updating Ubuntu from 13.04 to 13.10 has resulted in a black screen after selecting Ubuntu in GRUB. I can still select any other operating systems in GRUB without issue including Ubuntu's Recovery Mode.

My current GRUB2 options are:

Ubuntu (<-- this is the one that black screens, 13.10)
Ubuntu Recovery Mode
Mint Recovery Mode
Ubuntu (different, old install, 13.04)
" Recovery Mode
Windows 8 (here at the moment)

A bit of searching suggested that it's a kernel issue with UEFI; my motherboard has no compatibility options so that's a no-go. There's also no "Previous Linux Versions" option/submenu under GRUB.

Is there any way of updating the kernel from the recovery menu? Or rolling it back? Or is it a completely separate issue?

Help appreciated.

  • You can try dropping to a root shell in the recovery menu then executing sudo apt-get update ; sudo apt-get dist-upgrade which will upgrade the terminal, but it may or may not help. – kiri Oct 27 '13 at 10:32
  • There's no network access in recovery though is there? – Sam A. Horvath-Hunt Oct 27 '13 at 12:12
  • Choose the netroot option to use a root shell with networking. – kiri Oct 27 '13 at 12:13
  • This is what I see: lh3.ggpht.com/-arrPwliiteM/UEySmgF2hTI/AAAAAAAAGW4/jzOdSRfeTCQ/… So do I type netroot into the terminal or use the networking option? Because selecting the networking option throws me a mounting error. – Sam A. Horvath-Hunt Oct 27 '13 at 13:44

Fixed it. Turns out it was an issue of my own creation with /etc/fstab. These are the steps I took to fix it:

1) Boot into Ubuntu's recovery mode and select the option that provides access to the root shell/terminal/command-line.

2) Enter the following to provide write access to the drive (incl/ crucially fstab):

#mount -n -o remount,rw /

3) Next you'll want to open fstab in nano (think of nano as the shell equivalent of gedit):

#nano /etc/fstab

4) Remove whatever you added there to cause the problem or comment it out with a hash (#). Hit Ctrl+X, then Y, then ENTER, or whatever other combination of keys (there's a guide at the bottom) allows you to save and write the changes and exit.

5) Enter the following to cleanly reboot. It may take a moment.

#shutdown -r now

If your problem is anything like mine that's it fixed. :-)


try this software it can help solve boot issues or grub related problems


  • Won't help, the problem seemingly is the kernel or some other updated part of Ubuntu 13.10. – Sam A. Horvath-Hunt Oct 27 '13 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.