First of all, I have checked a lot of similar topics, but I still can't get my laptop to use Nvidia 740M.

So first things first.
I have a laptop Asus X550V (i5-3230, 4gb RAM, Nvidia 740M + Intel HD4000). I installed Ubuntu 13.10 alongside Win8 (preinstalled) and both systems are running without problems. However, I have a problem with second graphics card (Nvidia 740M), as Ubuntu doesn't recognize it. I installed bumblebee with this tutorial, but I still get an error

Cannot access secondary GPU" error when trying to run ''optirun Steam'' in terminal.

Then I tried to do this:

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected. you need to edit the /etc/bumblebee/xorg.conf.nvidia (or /etc/bumblebee/xorg.conf.nouveau if using the noveau driver) and specify the correct BusID by following the instructions therein.

But with lspci / VGA I get only info about Intel 4000, but no Nvidia. When I type only lspci, I get the line for Nvidia 740M, but after I edit the config file I still get second card error.

Also, in /etc/bumblebee/xorg.conf.nvidia there wasn't BusID or anything similar, so I just added the whole line in device section.

As I said, I tried a lot of things to get it working, avoiding this forum (as I didn't want to bother people with some solutions possible), but alas!, I had to bother you.

If there is a need for some additional info, just say, no problem at all.

Thank you very much in advance. :)

  • just dont use bumblebee i really dont know why that thing exists... is so... bad – Egon Stetmann. May 24 '18 at 5:48

To find the correct BusID, use lspci | egrep 3D. Input the correct BusID in /etc/bumblebee/xorg.conf.nvidia. Then edit the file /etc/bumblebee/bumblebee.conf and the change the line Driver= to Driver=nvidia. Then, reboot your computer, and it should work.

| improve this answer | |

When I had the same problem (about two weeks ago).

I found that installing the nvidia-current drivers with bumblebee worked first time.
For some odd reason it would never find my Graphics card when using any other driver.

add-apt-repository ppa:bumblebee/stable
sudo apt-get install nvidia-current
sudo apt-get install bumblebee bumblebee-nvidia

If still not working

    sudo gedit /etc/bumblebee/bumblebee.conf

    On the bottom of the first section you find

    change it to

    further down:
    ## Section with nvidia driver specific options, only parsed if Driver=nvidia
    # Module name to load, defaults to Driver if empty or unset
    KernelDriver=nvidia-current ------> Change to KernelDriver=nvidia

save - reboot

Hope this helps

| improve this answer | |
  • Hello all. Thank you for your replies. Unfortunately, it's not working. The problem is, that on Bumblebee chat someone gave me a link to a tutorial and there was something about updating Nvidia driver -319 and to change those config files. I did it, but now I can't use your tips. So I deleted Bumblebee completely and installed with your tips, but now when I enter those config files, they are still modified with those -319 drivers. Any chance to revert changes of config files to primary form? Then I would be able to change the file with your tips. Thank you. :) pastebin.com/ZubYvDAB – Jon Oct 29 '13 at 9:50

after so much trying i've clean everything with ppa-purge and restart with fresh instructions:

  1. enable ppa:xorg-edgers/ppa and install nvidia-331 (nvidia-graphics-drivers-331) and dependencies
  2. reboot
  3. enable ppa:bumblebee/stable and install bumblebee bumblebee-nvidia primus linux-headers-generic
  4. reboot
  5. optirun glxgears works now very very well!

I'm on the notebook Hp envy 17-j009el with kubuntu saucy and nvidia card:

01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff)
| improve this answer | |

I had the same problem with HP Pavilion GT 740M and I solved by installing Bumblebee. add the ppa to my system from the Xorg-Edgers PPA

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update

Since I was running with just the standard nvidia-current driver, I had to uninstall a few things. if you have other driver installed replace with current to remove.to check which nvidia driver you already installed run this command dpkg -l | grep -i nvidia .

sudo apt-get remove bumblebee-nvidia nvidia-current nvidia-settings

After this I then had to re-install with the newest version

sudo apt-get install bumblebee-nvidia nvidia-319
| improve this answer | |

i was having the same problem on my Vostro 5470, i've got a light from Lekensteyn who told me i would probably need a newer kernel, 'cause i wasnt been able to even work with BBSWITCH.

The first thing that i needed was update my kernel to the 3.12 version which i done by:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200-generic_3.12.0-031200.201311031935_amd64.deb && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200_3.12.0-031200.201311031935_all.deb && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-image-3.12.0-031200-generic_3.12.0-031200.201311031935_amd64.deb
sudo dpkg -i linux-headers-3.12.0-*.deb linux-image-3.12.0-*.deb
sudo reboot

Ok, with the new kernel working i then re installed bumblebee with new drivers.

sudo apt-get install nvidia-331
sudo apt-get --purge autoremove
sudo apt-get --reinstall bumblebee bumblebee-nvidia

Then i got this when trying to optirun glxgears:

error while loading shared libraries: libturbojpeg.so

For last i fixed that with:

sudo ln -s /usr/lib/x86_64-linux-gnu/libturbojpeg.so.0 /usr/lib/x86_64-linux-gnu/libturbojpeg.so

or if you're using 32bits:

sudo ln -s /usr/lib/i386-linux-gnu/libturbojpeg.so.0 /usr/lib/i386-linux-gnu/libturbojpeg.so

After all that i was able to make it run. Remember to turn on your GPU and restart bumblebeed after all these updates!

tee /proc/acpi/bbswitch <<<ON
sudo service bumblebeed restart
optirun glxgears
| improve this answer | |

This is what worked for me, and am pretty sure will work for you as well. My pc: 8gb ram, GT 540M, i7.

Install Nvidia Driver

Instruction bellow are what I have found in another website witch I copied all text. Can't remember the site tho:/

  1. I had to add the PPA to my system from the Xorg-Edgers PPA

    sudo apt-add-repository ppa:xorg-edgers/ppa
  2. Then update of course

    sudo apt-get update
  3. Since I was running with just the standard nvidia-current driver, I had to uninstall a few things:

    sudo apt-get remove bumblebee-nvidia nvidia-current nvidia-settings
  4. After this I then had to re-install with the newest version

    sudo apt-get install bumblebee-nvidia nvidia-319 nvidia-settings-319
  5. Then I just restarted my computer.

Even tho it says nvidia-319, it will install the latest drivers dont worry!

Also as a reminder to view your nvidia-settings screen, run it like so in a terminal

optirun nvidia-settings -c :8

I hope this helps out!

When you want to run a game with your nvidia drivers you simply write

primusrun something

if you want to run steam:

primusrun steam
| improve this answer | |

I too had same problem.

As per ubuntu wiki:-


you don't need ppa to install bumblebee

just enable universal and multiversal packages



sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic

If you have successfully installed bumblebee. And your computer don't detect the drivers at boot time. Just load the drivers to the current boot participation by running the below command.

sudo update-initramfs -u -k all

If you are want to know more about "update-initramfs". Just fire man update-initramfs.

All the best.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.