I am currently making use of a Wired Broadband. By default NetworkManager shows that the Auto Ethernet is connected. I was unable to browse through any websites in the browser. I had to disconnect & connect the Auto Ethernet several times in NetworkManager or restart Ubuntu to get it fixed. But following these steps is quiet annoying as this issue happens very frequently.

I browsed through the Internet and got to know that WICD Network Manager fixes this issue. Earlier I have been using Ubuntu 12.04 where the same issue was fixed by making use of WCID Network Manager.

Recently I upgraded to 13.10 and as I got the same network issue in default NetworkManager, I have installed WICD NetworkManager but when I try to open WCID, I get an alert message saying,

Could not connect to wicd's D-Bus interface. Check the wicd log for error messages.

When I click on OK, I get the same message again and when I click on OK again I get the following message,

Error connecting to wicd service via D-Bus. Please ensure the wicd service is running.

Any help to fix this issue is greatly appreciated as this issue was annoying me since I installed 13.10


This might be a symptom of this bug: https://bugs.launchpad.net/ubuntu/+source/wicd/+bug/1132529

The solution that worked for me was to run the following commands from the command line (see comment #22 from above link):

sudo service wicd stop
rm /etc/resolv.conf
rm /var/lib/wicd/resolv.conf.orig
ln -s /run/resolvconf/resolv.conf /var/lib/wicd/resolv.conf.orig
sudo service wicd start

Hope that helps!

  • 2
    I followed the above set of line commands from Chris and wicd worked. My connections are fine, but I no longer have access to the Internet. I am new to linux and desperately need my internet access back. How do I undo these steps? Any help would be greatly suggested. – Omar Jan 11 '14 at 22:33
  • This is performing ugly surgery on Ubuntu's mechanism for managing resolv.conf. Normally /etc/resolv.conf is a symbolic link to ../run/resolvconf/resolv.conf which is written by resolvconf based on information provided to it. – jdthood Jan 13 '14 at 12:24

protected by Community Apr 22 '14 at 7:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.