7

I've recently updated my Ubuntu to the 13.10 version. To my surprise, Ipython and Matplotlib are available only in versions prior to those I had in my previous 12.04 LTS install.

When with the 12.04, I had the Julian Taylor PPA set up in my repositories, and that's why (I think) I had most up-to-date versions from both packages.

The versions currently in 13.10 are:

Matplotlib: 1.2.1 (http://matplotlib.org/index.html, most current version is 1.3.1)

Ipython: 0.13.2 (http://ipython.org, most current version is 1.1.0 – September 2013)

Is there any PPA available for the 13.10? The JTaylor ppa covers only as far as 12.10 (Quantal, link not available due to reputation rank in stack exchange)

Should I install those packages outside apt? Isn't that troublesome?

  • Thank you for the creation of the two tags you added, but why remove the 13.10 tag? Isn't this related (version-wise) to the 13.10 release? – LuizAngioletti Oct 27 '13 at 3:12
  • No, since you can use the very same method to install into 13.04 12.04, etc. The main question here is how to install the bleeding edge (Ubuntu as whole doesn't include the bleeding edge as said my answer) so this answer is perfectly applicable to any system. – Braiam Oct 28 '13 at 9:42
7

The way to fix it is using pip.

The way to set up pip is described here: http://docs.python-guide.org/en/latest/starting/install/linux/#install-linux and it sums up to:

(I think python-distribute comes pre-installed in 13.10, but it doesn't hurt to check)

sudo apt-get install python-distribute

Then we set up the python environment properly:

sudo easy_install pip
sudo pip install virtualenv

After that, do:

sudo pip install ipython[all]

This will let pip take care of the dependencies listed by ipython. At this point, IPython is already working properly.

OPTIONAL, installing matplotlib and numpy:

These take care of the dependencies for matplotlib and numpy (and assuming you already have LaTeX properly installed):

apt-get install libfreetype6-dev libpng-dev libpython-all-dev gcc gfortran dvipdf

partial ref: https://stackoverflow.com/questions/8359383/error-while-installing-matplotlib

I'm aiming for something like this:

    ============================================================================
Edit setup.cfg to change the build options

BUILDING MATPLOTLIB
            matplotlib: yes [1.3.1]
                python: yes [2.7.5+ (default, Sep 19 2013, 13:49:51)  [GCC
                        4.8.1]]
              platform: yes [linux2]

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [version 1.7.1]
              dateutil: yes [using dateutil version 2.1]
               tornado: yes [using tornado version 3.1.1]
             pyparsing: yes [using pyparsing version 2.0.1]
                 pycxx: yes [Couldn't import.  Using local copy.]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: yes [version 16.1.10]
                   png: yes [version 1.2.49]

OPTIONAL SUBPACKAGES
           sample_data: yes [installing]
              toolkits: yes [installing]
                 tests: yes [using nose version 1.3.0]

    OPTIONAL BACKEND EXTENSIONS
                macosx: no  [Mac OS-X only]
                qt4agg: yes [installing, Qt: 4.8.4, PyQt4: 4.10.3]
               gtk3agg: yes [installing, version 3.4.8]
             gtk3cairo: yes [installing, version 3.4.8]
                gtkagg: no  [The C/C++ header for gtk (gtk/gtk.h) could not
                        be found.  You may need to install the development
                        package.]
                 tkagg: no  [The C/C++ header for Tk (tk.h) could not be
                        found.  You may need to install the development
                        package.]
                 wxagg: no  [requires wxPython]
                   gtk: no  [The C/C++ header for gtk (gtk/gtk.h) could not
                        be found.  You may need to install the development
                        package.]
                   agg: yes [installing]
                 cairo: yes [installing, version 1.8.8]
             windowing: no  [Microsoft Windows only]

OPTIONAL LATEX DEPENDENCIES
                dvipng: yes [version 1.14]
           ghostscript: yes [version 9.10]
                 latex: yes [version 3.1415926]
               pdftops: yes [version 0.24.1]

So, if I just missed any dependencies, just comment below ;)

Then, using pip:

sudo pip install matplotlib[all]

It compiles, and done. Ipython, numpy and matplotlib ready for science in Ubuntu 13.10.

| improve this answer | |
0

First of all read: Why don't the Ubuntu repositories have the latest versions of software?

Once you have read that, you should be aware that the ipython-notebook package is in the universe repository. This repository is maintained by the community, or in this case by Debian. So, if you want more updated package, for whatever reason, you should use manual methods. BTW, the package is only 2 releases behind 0.13.2 -> 1.0.0 -> 1.0.1 trough the changes were extensive I don't expect the maintainer testing one by one each commit and check what could get broken.

Same with Matplotlib, only 2 releases behind but there were several changes between each version, and maintainers have better things to do that bringing bleeding edge, since the selling point of Ubuntu is stability over everything. If something imply several testing (and more with low priority package) it will take a while to bring the latest. This could be more lucky in the next releases since Debian has the 1.3.1 version in sid/unstable repositories. Maybe for the next Ubuntu release cycle.

How to install the bleeding edge? Ask a new question for each package.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.