10

It seems the bluetooth subsystem shows some bugs after the upgrade to 13.10. It was working quite happily at 13.04.

The bluetooth mouse I have, simply won't connect after the computer goes into any sort of sleep and has to be re-added each and every time. Sometimes the the entire bluetooth stack has vanished alltogether.

What changed with the bluetooth between these versions, that may cause this?

This is a fresh install of Kubuntu I'm using (bluedevil) no an upgrade, but the same hardware as 13.04 was happy on.

I have reported this as a bug https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1246981

and added the link here as requested.

  • The same happens with Ubuntu Unity, so it is not exclusively an issue with the KDE-stack and tools. – berkes Oct 27 '13 at 13:19
  • This post was edited two days ago to tone it down. Sorry, I object. This release is the worst by FAR for a considerable time. The Bluetooth stack has gone backwards considerably, akonadi is segfaulting constantly and muon-updater consistently fails to fully load the package list full after an update. Small things possibly, but pretty poor in total. – Peter NUnn Oct 29 '13 at 22:32
  • Whether or not the release broken things matters nothing: The is a QA site, not a place to rant. We can help you solve your actual, technical, problem. But we cannot help you fix your mood. – berkes Oct 30 '13 at 10:15
  • OK, fair call. How do I fix the issue that the mouse continues to not reconnect when the laptop resumes and that bluetooth mobile networking through a tethered device no longer works? – Peter NUnn Oct 31 '13 at 5:07
  • Bug report filed. No traction their either. – Peter NUnn Nov 3 '13 at 8:48
6

Don't want to resurrect an old question but I had this same issue in Arch and now in Ubuntu 14.04. I've been able to find a permanent work around on both systems. For those Googling for a solution this is what worked for me. Your mileage may vary. For Ubuntu I follow instruction from the BluetoothSetup wiki page specifically the instruction for 11.04. For easy sake here are the steps I went through.

  1. Make sure you unpair and disconnect your mouse completely
  2. Set device in Pair mode
  3. Open Terminal and run

    hcitool scan
    

    Make note of the Mac address of your device in the format of XX:XX:XX:XX:XX:XX

  4. Next, enter:

    sudo bluez-simple-agent hci0 XX:XX:XX:XX:XX:XX
    sudo bluez-test-device trusted XX:XX:XX:XX:XX:XX yes
    sudo bluez-test-input connect XX:XX:XX:XX:XX:XX
    
  5. After this you can restart bluetooth service, sleep the laptop, turn off and turn on the mouse to check.

The two main points are the last two lines in step 4. I believe they are what make the connect permanent. Their order is important it they just need to ran together.

1

What I am doing now is selecting the mouse on the bluetooth icon and click on disconnect, after the bluetooth icon blinks I do connect and the mouse works again.

  • It seems to hae been fixed with the recent update. At least, I ran the updates this morning and rebooted and now my Mouse remains active. Can anyone confirm? I cannot find a ticket in launchpad for this bug. – berkes Oct 28 '13 at 9:13
  • My computer still continues not responding to the bluetooth mouse when it wakes up after suspend, i still need to disconnect and connect the mouse as i said before. – Carlos Kassab Oct 29 '13 at 17:46
  • Correct: It simply does not occur always. But I confirm that it does still happen. – berkes Oct 30 '13 at 12:53
  • Unfortunately this has no effect on my Kubuntu install. Still not working. – Peter NUnn Oct 31 '13 at 5:07
  • That is a solution, true. But not a very efficient one. – Evorlor Jan 22 '14 at 22:47
1

The Bluetooth Manager utility seems to do a better job of pairing with the mouse. I believe that, as you can see in Atalaia's answer, the step of trusting the device is important, and the built in bluetooth tools don't always do that correctly.

Install the blueman package, run the "Bluetooth Manager" application, completely remove the mouse, pair it again, and mark it as trusted. You should only have to do this once.

Not the answer you're looking for? Browse other questions tagged or ask your own question.