I want to install Google-Earth & it requires ia32-libs. So, I did apt-get install ia32-libs but error pops as:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

How can I install ia32-libs?

6 Answers 6


This is only a workaround until Google Earth is repackaged.

Google Earth Build Package

  1. Download Google Earth x64 .DEB
  2. Open Terminal, Copy & Paste Following Command And Press Enter

    sudo apt-get install libc6:i386 lsb-core
  3. Open Downloads Folder

  4. Right Click On Google Earth .deb package & Select Extract Here
  5. Open the folder where files are extracted.
  6. Open the DEBIAN Folder
  7. Open the control file with gedit
  8. Remove this whole Line: Depends: lsb-core (>= 3.2), ia32-libs
  9. Now Click Save, & Exit Control File
  10. Now Delete The Original Google Earth .DEB Package You Downloaded

  11. Create A Folder called getfix, Now Move The Extracted Google Earth Folder Into The getfix Folder

Now we Are Going To Rebuild The Google Earth .deb Package:

  1. Open Terminal, copy/paste the following command then press Enter:

    dpkg -b ~/Downloads/getfix/google-earth-stable_current_amd64
  2. Copy/paste the following command (this will install the repackaged .deb)

    sudo dpkg -i ~/Downloads/getfix/google-earth-stable_current_amd64.deb
  • 3
    Currently, this won't work. The package will install but GE will fail to start. [0324/121420:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses() [0324/121420:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler. Another crash happened while handling crash!
    – math
    Mar 24, 2014 at 11:21
  • Same problem here: [0330/183031:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
    – jgomo3
    Mar 30, 2014 at 23:01
  • It has worked, this solution works on my Ubuntu 13.10 64bit.
    – indago
    May 8, 2014 at 9:14
  • 1
    Works on my Ubuntu 14.04 64bit as well.
    – fdetsch
    Feb 10, 2015 at 13:37

For Ubuntu 13.10/14.04/1404.1 64 bit installs

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 \
libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 \
libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

For Ubuntu 14.04.2 image 64 bit installs (when using the 14.04.2 image you get the mesa-lts-utopic stack so one package is different, ie. libgl1-mesa-glx-lts-utopic:i386

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 \
libglu1-mesa:i386 libgl1-mesa-glx-lts-utopic:i386 libxext6:i386 \
libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

Then get the current i386 package & install it - http://www.google.com/earth/download/ge/agree.html

  • 2
    Did work (2014-03-24). The 64-bit deb seems to be somewhat broken.
    – math
    Mar 24, 2014 at 11:25
  • This even works for PlayOnLinux Jun 12, 2014 at 3:46
  • This is the only thing that has worked for me, and i tried a lot of different methods. I really wish this was added to the Google Earth Ubuntu documentation! Knowing what my exact install version was and using the 2nd set of commands was the key.
    – kim holder
    Sep 9, 2015 at 22:17

At the time of writing this answer all the methods described here didn't work. However I installed the 32 bit version and it worked fine on 64 bit 13.10 Kubuntu. It seems that the Google Earth package is 32 bit after all and it uses the ia32libs to make it run on 64 bit. Hope this helps


After extracting .deb package, I cannot find the Debian folder, so not editing to modify contents line, much less rebuilding the package etc... this is a bit too complicated for non geeks.

Why not simply obtain the 32 bit stable package?:http://www.google.com/earth/download/ge/agree.html

as explained here in ubuntuforums: http://ubuntuforums.org/showthread.php?t=2183733

That worked for me :)


This problem has been fixed in Debian Jessie/Sid, since it's not synced with Saucy/Raring I uploaded the fixed versions to googleearth-package PPA:


  • 2
    Suggesting that people "just use a PPA" is not going to be very safe, as PPAs are third-party, unsupported repositories...
    – Thomas Ward
    Nov 10, 2013 at 1:17

Just install the 32 bit version. It works fine. Here is my reference https://help.ubuntu.com/community/GoogleEarth

  • The wiki has/had an incomplete install list for 64bit using 32bit .deb, fixed it
    – doug
    May 2, 2014 at 20:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.