8

After upgrading to 13.10, I am now getting a prompt for my gmail password every time I log in. There is no indication as to which service or application needs this information. If I enter the correct password I'm told it is incorrect. My gmail account does not use two factor authentication. The problem has only started after an upgrade from 13.04 to 13.10.

How can I prevent this prompt appearing, and/or what is doing the prompting?

4
  • 2
    Can you provide a screenshot of the same scenario? – Saurav Kumar Oct 26 '13 at 21:17
  • 1
    Did you configure the email client to use GMail? That would be why it's asking for your password when it loads up. However, if you did not, then please show us a screenshot (and black out data you don't want us to see like your email) of what exactly the prompt looks like. – Thomas Ward Oct 26 '13 at 21:29
  • 1
    Same problem for me. Impossible to get a screenshot. It doesn't work but I get a photo : ubuntuone.com/7FxDC3vztrNGGPtTJXvYMO It's a small window at the top left of the screen and you must close this window to use the other applications. I'd an online account for google : I removed it but I have the same prompt yet when I log in. – arverne Oct 28 '13 at 7:21
  • My email client (Thunderbird) does connect to gmail, however as I said in the question it doesn't matter if I enter the correct password, I still get the response that it's incorrect. The link to the photo in the comment above shows the problem – user208080 Oct 29 '13 at 22:19
8

I was facing the same issue and got rid of it by just removing the evolution and goa-1.0 folders from my ~/.config.

0
6

Well I haven't managed to find out exactly why I'm getting asked for the password, but I've managed to stop it happening. I renamed my ~/.config directory and then let the logout/login process create a new one. Then by a long process of copying entries from my old .config to my new one, I've found out that the problem lies somewhere in the three directories evolution, desktop-couch and goa-1.0. As the prompt has stopped and I don't use evolution ( and I don't know what desktop-couch or goa-1.0 are) I've left it at that.

Hopefully this will let someone else fix their system and/or explain what is going on.

2
  • "goa-1.0" is Gnome Online Accounts 1.0 – Alex Dueppen Aug 11 '14 at 15:40
  • I had to tweak some configuration on API access on the google account, as the evolution's logins were blocked by Google. – franzlorenzon Oct 24 '14 at 8:53
0

Thank you, thank you guys, this is the only solution that worked for me - I tried the other dead-ends: remving all "keyring" folders from "~/.config"; using "seahorse" to try to change the "Login" password to match my Ubuntu password. None of these worked, in particular, you cannot change the "Login" password in "seahorse" without knowing the "Old" password and it seems that seahorse doesn't know what that is either, because I tried all my known passwords.

So the answer for me was:

rm -rf ~/.config/goa-1.0

and I suspect that the offending directory is the "goa-1.0" one, because after I deleted the "evolution" one and rebooted, I still got the keyring / gmail password prompt, but then I deleted them both (the evolution one had reappeared) and voila the prompt disappeared.

Thanks guys.

Not the answer you're looking for? Browse other questions tagged or ask your own question.