Last week I installed Ubuntu on my notebook, now I'm also trying to install it on my PC, but with no luck.

When i start from my USB stick (same as I installed my notebook with, Ubuntu 13.04) first I'll see an purple screen, after this it shows a black screen, blinking cursor and the a small line on the left is purple.

I've started searching on Google, and tried the nomodeset function on the first black screen. Here it doesn't show the purple line on the left, but still an black screen with blinking cursor..

Now I tried to install 13.10 and 12.10 on the USB stick, but with no luck. Exactly the same things happened.

After this, I tried some other things:

acpi=off = Same effect as nomodeset.

nolapic = Same as "normal" boot (purple line, black screen), but without the blinking cursor.

Desktop specifications:

  • Intel Xeon E3-1240 V2
  • GeForce GTX 640 Ti BOOST
  • 6GB of memory
  • 3 displays, the purple line is always on the "main" screen (middle one).
  • Currently windows 8 pro installed.
  • ASRock B75 Pro3-M
  • Install nvidia-driver, in dash search for software & updates, open it, goto additional driver. – Web-E Oct 26 '13 at 20:06
  • 1
    How can I install anything? it doesn't even boot :S – Wouter0100 Oct 26 '13 at 20:07
  • 1
    Ohh.. Sorry disabled secure boot? See askubuntu.com/q/162075/35775 . Also this may be useful too - askubuntu.com/questions/221835/…. Most probably the problem is coming from UEFI – Web-E Oct 26 '13 at 20:13
  • CSM is enabled, Secure boot is disabled. When i start and open the boot devices, i see USB: PMAP (I always use this) but also UEFI: PMAP. If i select the UEFI one, i get an GRUB screen where i can choose between Try ubuntu, Install Ubuntu, Oem install and check disc for defects. – Wouter0100 Oct 26 '13 at 20:37
  • And Confirm-SecureBootUEFI in Powershell returns Cmdlet not supported {more} – Wouter0100 Oct 26 '13 at 20:44

You could try this and see if it lets you access the desktop:

When hard-drive has stopped loading and you are sitting on a black screen, press CTRL+ALT+F1 and enter your username and password and press ENTER.

Now type: startx which should run xorg and bring you to your desktop...

If this works, open a new Terminal window on your desktop and remove LightDM by typing the following:

   sudo apt-get remove lightdm

and then done we'll replace it with GDM instead by typing:

   sudo apt-get install gdm

now type: sudo reboot to reboot computer and hopefully all is well...

  • Could the NVIDIA card be the problem? Is that's why you're suggesting this? – Marlinc Jan 15 '14 at 8:50
  • It's one solution to newer machines hanging at bootup, sometimes caused by lightdm or yes, it could be noveau open-source driver hanging on your nvidia card... Another solution is to press CTRL+ALT+F1 on black screen and typing: sudo apt-get install nvidia-current in the hope of installing the latest nvidia binaries so your card will be running it's own driver set... – TenPlus1 Jan 16 '14 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.