87

I'm running Ubuntu 13.10 with dual boot along side Windows 8.

The top panel or bar doesn't display the time.

When I open the Clock menu, all the settings over there are grayed out
Settings > Time and date > Clock

I tried other methods (like dconf) but that didn't work.

4
  • I have no idea what do you mean with "greyed out". Please, take a screen shoot! – Lucio Oct 26 '13 at 20:23
  • 1
    I have precisely the same issue. "Grayed out" means that none of the options / check boxes in the Clock tab are responsive. – Luís de Sousa Nov 12 '13 at 19:54
  • Having same issue and reinstalling Gnome-control-center and restarting lightdm don't fix it for me... – dartdog Feb 19 '14 at 17:29
  • found answer here maketecheasier.com/date-time-missing-ubuntu-1310 – dartdog Feb 19 '14 at 17:33
169
  1. Reinstall indicator-datetime. It should be installed by default, but just in case you have removed it unknowingly, it is best to run the install command again.

    sudo apt-get install indicator-datetime
    
  2. Next, we are going to reconfigure the date time:

    sudo dpkg-reconfigure --frontend noninteractive tzdata
    
  3. Lastly, restart unity.

    sudo killall unity-panel-service
    

That’s it. The date and time indicator will appear in the menu bar now.

(Source)

4
  • 2
    Worked for me and I didn't lose my session, thanks. – Cheezey Mar 6 '14 at 22:58
  • 43
    Just doing step 3 worked for me (you could try it first, and if it doesn't help perform the other steps): sudo killall unity-panel-service – kaiwan Jul 4 '14 at 6:41
  • I just needed to kill unity-panel-service in order to work for me. – Paulo Aug 23 '16 at 11:20
  • perfect!!!!!!!!!!!!!!!! – Davinder Kumar Oct 4 '17 at 4:14
81

For me, it was enough to restart unity:

sudo killall unity-panel-service
2
19

WARNING: All users will logout immediately, possibly losing data. All applications will also close.

It is happening to me sometimes, the solution is:

sudo restart lightdm
5
  • 11
    It's worth mentioning that this will logout all users immediately, possibly losing data. – kiri Oct 27 '13 at 5:57
  • 3
    Indeed, this is an annoying solution, but alas, it is a solution. – Luís de Sousa Nov 12 '13 at 19:59
  • @minerz029 I have edited the answer to include your comment as it is an important information for people trying out the above command. – palerdot Sep 20 '14 at 17:27
  • 1
    There is a better solution mentioned: i.e: sudo killall unity-panel-service – igauravsehrawat Jan 31 '15 at 4:42
  • 1
    I've managed to also get the bug in Ubuntu 14.04. Happens from time to time. – Mythul Feb 16 '15 at 10:41
3

I've been in the same situation myself once. What I've made was to reinstall gnome-control-center using the following commands in terminal:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install --reinstall gnome-control-center

After I restart the GUI from tty1 uing the following command:

sudo restart lightdm

the problem didn't appeared again until now.

0
0

It means your chosen region is not matched to your local server.

To correct: 1/ set the time&date to your actual region (eg China) 2/ use synaptic to select the repository server for your actual region (eg China). 3/ reboot.

This should solve the issue. Recurrence may be caused by change in location, or change in server, or update/upgrade. If so, repeat the above.

0

Or you can simply restart your computer. Time will show itself on the top panel again. I have also faced this problem a few times.

Because sometimes sudo lightdm restart won't work

Not the answer you're looking for? Browse other questions tagged or ask your own question.