3

I have an Asus Q500A with win8 and Ubuntu 12.04 64 bit with linux kernel 3.8.0-32-generic. I am using gnome-panel, and xserver-xorg-lts-raring.

I have been experiencing problems with the keyboard short-cuts since I had a fresh install.

Fn+F10 is supposed to mute my system, but instead it will repeatedly press d. Fn+F11 is volume down, but it presses c. Fn+F12 is volume up, presses b repeatedly.

Other on-board short-cuts such as adjusting screen and led brightness work most of the time, but sometimes press other letters repeatedly. Also, sometimes my Ctrl gets held down for no reason. Everything works fine in windows. I have tried installing all recommends and did sudo dpkg-reconfigure -a (use caution with this command) to reconfigure all packages, which did not solve my problem.

I have tried using KeyTouch editor to edit keymaps, navigating to /usr/shar/x11/xkb/keymap when I try opening any of these files it says file contains no keyboard element.

I think If I were just able to remap my keyboard it might solve my issues, otherwise if anyone knows where I can get asus drivers for 12.04 please let me know.

Apparently I didn't have all repositories enabled. I executed the following commands and am trying the updates they give me. Getting linux_kernel 3.8.0-33 generic as well as a bunch of other packages:

sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) universe"
sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse"
sudo add-apt-repository "deb http://archive.canonical.com/ubuntu $(lsb_release -sc) partner"

I tried using keytouch along with keytouch-editor to set my extra function keys. It reads the keys when I press them, but then they don't function as I set them.

I tried using showkey -k and pressing the keys to see how they are read. I noticed the problem key combonations do not read as being released. Just pressed. The other keys do display released.

7
  • I wish you all the best! Although I want you to test your system while booting Live CD/DVD/USB. Do you get same problem. you can easily make your Pen-drive boot-able using Startup Disk Creator Commented Oct 26, 2013 at 19:52
  • I have tried that with 12.04 12.10, and 13.04. Same problems. I also tried a fresh install on a different hard drive to no avail.
    – hydroxide
    Commented Oct 27, 2013 at 1:39
  • Okay, I updated everything after getting those repositories enabled, then I redid sudo dpkg-reconfigure -a and reconfigured xorg with no luck... (I made sure I removed all residual packages first.)
    – hydroxide
    Commented Oct 27, 2013 at 17:43
  • when I boot into Ubuntu it says "unable to write bytes: broken pipe" I looked around and it is related to drivers. I am wondering if there are drivers for my system for Ubuntu.
    – hydroxide
    Commented Nov 3, 2013 at 4:34
  • I have my keyboard set to not press keys repeatedly which is working around my shortcuts repeatedly pressing keys. My system is running better on xserver-xorg-lts-raring. The mouse-pad has been working most of the time. Keyboard shortcuts still not working right tough.
    – hydroxide
    Commented Nov 3, 2013 at 4:49

3 Answers 3

2
+25

This sounds like an issue with the asus acpi kernel module, try running the latest version from ACPI for Asus Laptops and see if that fixes the issue. Additionally take a look in /etc/acpi/ folder and see if you have any asus specific scripts and settings there yet. Does xev show only the normal letters that were being repeated, or also the XF86 keyevents?

16
  • I ran sudo apt-get install acpi which I apparently did not have! Still having mostly same issues, but I noticed that showkey -k now does respond to me releasing problem keys (See above edit). I will try rebooting and messing around with keytouch and will get back to you!
    – hydroxide
    Commented Nov 16, 2013 at 0:17
  • Okey, now after reboot it is no longer recognizing key release for problem key combos. It does recognize key release for keys individually, but when I hold fn+f11 for example it says "keycode 46 press" but not release. When I press f11 by itself it does recognize release. Some fn combos do work. Also, other keys besides h do not work the first time I press them, such as c. These seem to be the keys that are pressed when I try to use the fn combos instead of intended function. The first time I Use fn11 after booting it adjust the volume as desired, but then either does nothing, or holds down c
    – hydroxide
    Commented Nov 16, 2013 at 0:31
  • 1
    Normally update-grub should automatically detect all kernels in /boot. If for some reason that fails,you could allways just edit the /boot/grub/grub.cfg manually and copy and paste an existing block and change the path to the appropriate kernel. Commented Nov 16, 2013 at 12:58
  • 1
    You mention you didnt have the package acpi installed (actually this is not strictly necisarry AFAIK), is the package acpi-support by chance also not installed? If I am not mistaken, this package contains the event handlers and so forth. On a side note have you seen the page wiki.ubuntu.com/Hotkeys/Troubleshooting yet? Maybe it contains some helpfull hints. Commented Nov 16, 2013 at 13:04
  • 1
    Did the tips from the hotkeys troubleshooting page help in any way? Commented Nov 19, 2013 at 21:00
0

All my hardware is now working with both 14.04, and a fresh 12.04 desktop install. Unfortunately, I never actually found out what was going wrong, but I've been testing for about 3 weeks now and everything works perfect.

0

I have right the same prolem with my Q500A on ubuntu 13.10 . But curiously it sometimes working on and off .

As you seem to have an intensive research on this key bug . I've decide to abort to solve it. I've just change the short cut in the keyboard setting (sound-media)

something like ctrl+f11 instead of fn+f11.

2
  • I did finally just make a new shortcut for my sound options. What annoys me the most is the ctrl and alt keys arbitrarily thinking they are being pressed. Do you have that problem as well?
    – hydroxide
    Commented Apr 20, 2014 at 21:59
  • The hardware in my asus q500a seems to be working in Ubuntu 14.04.
    – hydroxide
    Commented May 22, 2014 at 2:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .