1

I cant seem to play any audio with CMUS because it always gives the above error

the output of

 lspci -v | grep -A7 -i "audio"

gives

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02) Subsystem: ASRock Incorporation Device c892 Flags: bus master, fast devsel, latency 0, IRQ 49 Memory at dff00000 (64-bit, non-prefetchable) [size=16K] Capabilities: Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])

what could be the problem?

0

cmus appears to default to the pulseaudio output plugin.

However the pulseaudio sound system is not necessarily installed on a headless server.

Try :set output_plugin=alsa or :set output_plugin=ao to switch to a supported backend.

  • thanks, i tried both but i still get the same error – clamp Nov 3 '13 at 16:12
0

I know that this is incredibly old but I've run into the same issue and no where has an answer of any kind. To fix this problem I installed

sudo apt-get install libao-ocaml-dev

and that seems to have fixed my problem.

My symptoms were that I could play music if I was root but would the error described by OP if I wasn't. I needed to compile cmus from source because the version of cmus that I get from apt was unable to play some of my music because of an ffmpeg/avconv issue.

I didn't need to do anything special aside from install that library.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.