This question is now obsolete since Chromium and its derivatives like Google Chrome use the more modern PPAPI Flash Player plug-in. It's built in to Chrome, but Chromium users need to rely on other solutions.

I being a developer want to use Flash version 10.1 or older on some of my Ubuntu machines. The problem is each time I run Google Chrome on this Lucid 64 bit machine (which is the only machine with me) I get a warning:

This flash plugin was blocked because it is out of date

As per instructions on these links:

then I tried at a command line:

google-chrome --allow-outdated-plugins

But I still got the same warning. Is there a way I can use with an old version of flash plugin?

As per below suggestion I edited the hex value of one of the file /usr/lib/firefox/plugins/flashplugin-alternative.so /usr/lib/iceape/plugins/flashplugin-alternative.so /usr/lib/libvisual-0.4/morph/morph_flash.so /usr/lib/openoffice/basis3.2/program/libflashlx.so /usr/lib/xulrunner/plugins/flashplugin-alternative.so /usr/lib/flashplugin-installer/libflashplayer.so /usr/lib/midbrowser/plugins/flashplugin-alternative.so /usr/lib/xulrunner-addons/plugins/flashplugin-alternative.so /usr/lib/mozilla/plugins/flashplugin-alternative.so /usr/lib/iceweasel/plugins/flashplugin-alternative.so /usr/share/ubufox/plugins/npwrapper.libflashplayer.so /var/lib/flashplugin-installer/npwrapper.libflashplayer.so

which was
From 10.1 to 10.2 but there was no effect.How do I find out which file is google-chrome using from above?

UPDATE 2 Following from lsof output I found


is the flash plugin which google chrome is using and there I could not find the string Flash 10.1 as mentioned in reply below.

  • 4
    Chrome blocks older Flash versions because they have known critical security bugs. Why are you trying to develop for old Flash? – Jeremy Bicha May 2 '11 at 22:53

Google Chrome will always block older versions of Flash. I think you might be better off either using another browser or an updated version of flash, because Chrome is not going to play nicely with old flash no matter what you do.

  • Not sure why you say, "no matter what". Is this a known issue? – Ramón Apr 27 '11 at 2:30
  • 2
    @Ramón: yes, it's a problem with security and old flash versions. Google Chrome will always block older versions. – RolandiXor Apr 27 '11 at 2:35
  • This is a useless answer. First, Chrome gives you the option to "Run this time", so it can definitely "play nicely". Second, Adobe is no longer developing Flash and officially dropped support for Linux years ago, so trying to upgrade Flash is impossible and using a different browser won't magically find a version of Flash that's more up to date. – Cerin Sep 14 '17 at 14:24
  • Did you check the date on my answer before you wrote this? – RolandiXor Sep 14 '17 at 16:23

Chrome seemed to use an outdated version located in /usr/lib/mozilla/plugins, so finally this works for me:

sudo rm /usr/lib/mozilla/plugins/libflashplayer.so

sudo apt-get install adobe-flash-properties-gtk adobe-flashplugin


If Roland is right and there is no way to disable this warning in some official way, then maybe you can give this a shot (I just tried the reverse, changing 10.2 to 10.1 and Chrome now blocks Flash by default with the warning):

Install a hex editor like ghex

sudo aptitude install ghex

From a terminal, enter the chrome directory.

cd /opt/google/chrome

Make a backup copy of the flash player library in your home directory.

cp libgcflashplayer.so ~/.

Open the library in ghex and search for "Flash 10.1" (type in the right pane of the search dialogue).

sudo ghex2 libgcflashplayer.so

enter image description here

Close the search window and modify the version number from 10.1 to 10.2. Save your changes. Any tab with Flash running will crash at this point. Restart Chrome and test your change. With luck it will work.

Now note, I imagine this will also affect anything else that checks what version of Flash you are running so keep that in mind for whatever tests you are doing.

  • surprisingly there is no file with name libgcflashplayer.so in the said location. – Registered User Apr 29 '11 at 11:03
  • 1
    Hmm...check "about:plugins" in Chrome and then hit the +Details link in the upper right to get the correct file path. – Ramón May 3 '11 at 23:32
  • My chromium has loaded flash player 10 and 11 and I disabled flash player 10, then the warning has gone :) – digz6666 Mar 11 '12 at 8:17

I downloaded the .tar.gz package from the Adobe website and copied libflashplayer.so in /usr/lib/mozilla/plugins to solve this issue.


I started having this problem with Ubuntu 11.10.

I read every single reply here but none worked. Eventually I browsed /opt/google/chrome/plugins and found three outdated files there. The three outdated files were:

libflashplayer.so Nov 2 2010

libflashplayer.so.64bit Jul 23 2009

libflashplayer.so.org Nov 14 2008

I created a folder called: /opt/google/chrome/plugins/backup and move all three files there.

I then went to http://get.adobe.com/flashplayer/ and downloaded the .tar.gz for other Linux.

I extracted the file libflashplayer.so to /opt/google/chrome/plugins and finally after months of frustration the problem is sorted out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.