13

I have a HP G62 laptop with Intel Pentium processor and ATI graphics. Since upgrade to Ubuntu 13.10, my Unity menu is very slow and unresponsive. I am using proprietary driver for my graphics

For example, I'm switching between Gimp and Chrome. When I switch to Gimp, I will be stuck with Chrome menu at the top of the screen. It is really annoying and it is just one of many bugs that came up with 13.10.

Any ideas? Should I just revert to default driver?

4
  • Could it be that this only happens when Gimp is opened? In that case it could be this bug: Menus are very slow to load If so, it would be good to add yourself to the list of affected users and maybe write a comment describing your machine and your situation. This would help raise attention for the bug and –more importantly– for it being solved.
    – user209887
    Oct 31, 2013 at 12:42
  • 1
    Mostly with gimp, but also with Sublime Text 3
    – VukBG
    Oct 31, 2013 at 13:03
  • I don't think changing the driver will help, NVidia & Intel people are reporting the same issue (e.g. askubuntu.com/questions/368541/…). The best conversation to watch on this issue is at bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1199877
    – Eric Caron
    Oct 31, 2013 at 14:17
  • when you disable unity plugin on compiz settings manager, and enable again, works fine, maybe be a light for anyone else, maybe on a computer under amd the unity plugin be loaded after amd drivers or native drivers.
    – user273273
    Apr 23, 2014 at 20:11

2 Answers 2

7

This fix for this issue got released on 2013-11-01 (https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1199877/comments/73). Just keep an eye out for gtk+3.0 in the Softare Updates and apply it once it arrives on your machine. I can confirm that this fix solves it for me.

5
  • Downvote removed, have a nice day :)
    – Thomas Ward
    Nov 1, 2013 at 18:39
  • How do you install it before t lands in the official repos? Terrible bug indeed
    – akmur
    Nov 5, 2013 at 15:49
  • I still suffer from this issue to this day :( very bad bug
    – akmur
    Nov 15, 2013 at 14:52
  • Me too. Any word on when this update hits the repos?
    – Hubro
    Nov 21, 2013 at 23:33
  • I am still experiencing it
    – akmur
    Nov 24, 2013 at 23:29
-1

I have run into similar issues when upgrading to new Ubuntu versions. Usually, ATI Graphics cards don't usually play well with Ubuntu. Try reverting back to the default driver or look for other updated version that might work with your system. Good luck!

Not the answer you're looking for? Browse other questions tagged or ask your own question.