3

I've recently upgraded to 13.10 and I can't find the option to hibernate. My computer doesn't play ball when I suspend it (screen doesn't reactivate upon lifting the lid) so in 13.04 I always used hibernate when lid closes. That option has now disappeared. When I go to power options the option to hibernate is not listed under "Close lid" actions. The only options are suspend and do nothing. I had this same problem with 13.04 but did the following to fix it:

Altered the file /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla to say

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

I've tried this again after the update and it doesn't appear to be solving the problem.

marked as duplicate by Seth, karel, user117103, Eric Carvalho, Braiam Nov 15 '13 at 1:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Try 'sudo apt-get update' 'sudo apt-get upgrade' sometimes it magically works – Aatish Sai Oct 25 '13 at 13:20
  • Hi thanks for the advice but sadly it didn't help. – user207489 Oct 25 '13 at 21:44
  • possible duplicated askubuntu.com/q/361734/169736 – Braiam Nov 11 '13 at 22:47
4

The same issue on my laptop. After upgrading to 13.10 Hibernate option disappeared in Power Settings -> when the lid is closed.

Did as mentioned in https://bugs.launchpad.net/ubuntu-docs/+bug/1232814 I.e

In file /var/lib/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

put this

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

After rebooting Hibernate menu reappeared in Menu. But still unavailable in Power Settings -> when the lid is closed

Not the answer you're looking for? Browse other questions tagged or ask your own question.