Adding to my sequel of things broken after the upgrade:

When I select shutdown from the KDE workspace, I only get back to the login screen. When I do sudo poweroff, I can halt the machine.

I have the impression that something is fundamentally broken with permissons on my system. Networking only works from a root shell, mounting as well and now shutdown.

What is up with all that?


My system was presenting exactly the same symptoms after the upgrade to saucy baulked halfway through at tex-common and some other packages, leaving me with a crippled laptop. Via chroot I reconfigured the policy packages as explained in your other thread dpkg-reconfigure policykit-1 policykit-desktop-privileges consolekit polkit-kde-1. I also finished off the upgrade with apt-get update && apt-get upgrade.

That probably helped, but still didn't give me a working network connection. What finally worked for me was pam-auth-update --force as explained here. So it looks like it was something "fundamentally broken with permissions".

  • Thanks for the insights on the cause of this trouble. I have a lot of tex packages installed, that might be similar. I have a fresh reinstall now, so I cannot say if your approach would have worked for me. Nov 10 '13 at 0:38

This helped. Thank you. However, the commands really didn't do anything. Added the following line in /etc/pam.d/common-session and then sound, wifi & shutdown/reboot all works just fine:

session optional        pam_systemd.so
  • Wait a minute. What is systemd doing in Ubuntu? Dec 1 '13 at 15:10
  • Ubuntu now has a stripped down version of systemd. IIRC, they split out logind from systemd. So, some parts of systemd is actually available in ubuntu. At least loginctl, hostnamectl etc. works on ubuntu. Jan 17 '14 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.