35

I have a problem recently my cam (built in) is really really dark when using Skype or cheese I can barely see anything, Only when I spot a light on the cam I can see it but really dark

I have a Sony Vaio F127FD , I am running Ubuntu 10.10 (Desktop edition) fully updated

Note: the webcam was fine I guess the problem has something to do with the latest updates

1
  • Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding more detail? askubuntu.com/questions/14008/… Commented Apr 23, 2011 at 3:02

5 Answers 5

36

Install guvcview (still works on 20.04, 22.04):

sudo apt install guvcview

On Image Control tab, there is a brightness slider control.

If Image Control is empty

Open the Video Controls tab and click on the Device dropdown, selecting the correct device.

5
  • And how do you use this for changing brightness? Commented Nov 26, 2020 at 8:03
  • 1
    On "Image Control" tab, there is a "brightness" slider control. Commented Nov 26, 2020 at 12:02
  • 1
    Ah, I see. Well, not. :-) On my Lenovo T490, the whole panel of the “Image control” tab is empty. Commented Nov 26, 2020 at 22:26
  • @TorstenBronger I also had no image controls, but if I run sudo guvcview then I see them. Commented Apr 17 at 17:46
  • 1
    Or, better: find the name of camera device(s) with sudo apt install v4l-utils, v4l2-ctl --list-devices. For each of the /dev paths listed, try starting with guvcview -d /dev/video0. Once I'd found the right path (it was /dev/video0 for me) I get the image controls, even without using 'sudo'. Commented Apr 17 at 18:04
23

If not already installed, install the Video for Linux 2 Universal Control Panel (v4l2ucp), that will allow you to adjust your video settings

1
  • This package was removed in 20.04. Commented Apr 17 at 17:30
8

Unfortunately the control panel, v4l2ucp, has been removed in 20.04 along with all other qt4 applications. The package is still available here, and it installs just fine as long as you have qt4 available from a third-party repo like the one in this answer.

3
  • On Ubuntu 20.04 sudo add-apt-repository ppa:rock-core/qt4 then sudo apt-get update. Download bionic/v4l2ucp package then install it sudo pdkg -i Downloads/v4l2ucp_2.0.2-4build1_amd64.deb. Fix broken dependencies sudo apt update --fix-missing and/or sudo apt install -f. Search for Video4Linux Control Panel on ubuntu installed apps (Super key). Enjoy it!
    – Moreno
    Commented Dec 3, 2020 at 18:49
  • Just tried adding that ppa and it's Not Found
    – Shanteva
    Commented Jan 25, 2021 at 15:59
  • 1
    @Shanteva, unfortunately that PPA is for 20.04 only. If you are on 20.10 you will have to find another way of installing qt4. You might be able to use that PPA if you add it manually (click "Technical details about this PPA").
    – krispy
    Commented Jan 26, 2021 at 16:55
7

What worked for me (on Debian, probably also works with Ubuntu):

sudo apt install xawtv
v4lctl bright 100%
1
  • It does work with ubuntu 20.04. (y) Thanks. Nice and simple.
    – gaoithe
    Commented Apr 26, 2021 at 10:30
4

I had a same issue in Ubuntu 18.04 and 20.04 and struggled a lot with this issue. Changing brightness is certainly the wrong answer.

My camera has its own logic which calculates the brightness according the light conditions (the proportion of the darkest and brightest part of the view).

In this case Guvcview is a good solution

$ sudo apt install guvcview

On Cap. Image tab, there are:

  • Exposure, Auto dropdown: change it to Manual Mode
  • Exposure (Absolute) slider: increase its value carefully till you get a beautiful bright image. It was 320 for me.

I had to do it once and it fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .