I tried to post to this thread Hardware wireless switch has no effect after suspend and 13.10 upgrade for if I understand their question I am having the same problem, but the answer option won't work for.

After suspend, the wireless is disconnected and the only way to get it to reinitialize/be recognized is to do a full restart.

At first I thought it was my gnome-shell (for lock screen disappeared there with 13.10), but when I switched to the default Ubuntu it's still doing it and it's kinda driving me nuts for I have to reopen all my files and browsers/tabs/windows every time. I don't know how to show the terminal stuff the above asker shows, but it sounds like the same issue and it only started with 13.10 upgrade a few days ago.

Any help would be much appreciated!!! -- Thanks so much, ser.


4 Answers 4


I don't know about a official fix of this problem, but

sudo service network-manager restart

works in the meantime.


Bof's answer solves the problem in a one off fashion, but these steps solved the longterm issue for me:

sudo touch /etc/pm/sleep.d/wakenet.sh

sudo chmod +x /etc/pm/sleep.d/wakenet.sh

sudo gedit /etc/pm/sleep.d/wakenet.sh

Insert the following lines:

case "$1" in
nmcli nm sleep false
exit $?

And then save.

Solution found here

  • Welcome to Ask Ubuntu! Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such.
    – RolandiXor
    Commented Oct 31, 2013 at 15:48
  • Thanks for the tip. I would love to just flag duplicates, but I don't seem to have the authority to do so and want to be able to give other users any assistance that I can. Is there any way for me to be able to mark duplicates for moderator review? Is there some other behavior that I can engage in to be helpful but not create more work for moderators? I'd hate to just leave a person's question languish if I am able to do something to help.
    – mrm
    Commented Nov 1, 2013 at 0:05
  • If you are able to flag at all (with a custom flag, for example), simply mention the two questions that are duplicates.
    – RolandiXor
    Commented Nov 1, 2013 at 21:21

I was having this same problem on Ubuntu 14.04 and after a couple of days of trying to fix it, I found a file inside /etc/pm/sleep.d/ which is called 99dw1704.
This file handles disabling and enabling the wl module on hibernate and suspend. All I had to do to fix it is to run: sudo chmod -x /etc/pm/sleep.d/99dw1704 and everything ran fine after this.


Run sudo killall wpa_supplicant (found in the Ubuntu bugtracker).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .