This seems to be a fairly chronic problem, as shown by the following questions:

How do I fix a "Wireless is disabled by hardware switch" error?

Wireless disabled by hardware switch on an Asus X550V

"Wireless disabled by hardware switch" after suspend and other hardware buttons ineffective - how can I solve this?

but no good solutions have been found!

Wireless works fine after a reboot, but after a suspend the hardware switch (for my laptop this is f12) has no effect on the wireless, it is just permanently off, and shows that it is with a red LED. All

My rfkill list all reads:

0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes
1: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: yes

Any combination with rfkill <un>block wifi doesn't work, although one time first blocking then unblocking actually turned it on again.

sudo lshw -C network reads:

    *-network DISABLED
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 78:e4:00:65:2e:3f
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.11.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:90100000-9010ffff
  *-network DISABLED
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: c8:0a:a9:89:b4:30
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:2000(size=256) memory:90010000-90010fff memory:90000000-9000ffff memory:90020000-9002ffff

Also, adding a /etc/pm/sleep.d/brcm.sh file as recommended here simply prevents the laptop from suspending at all, which of course is no good.

This question has an answer urging to install the original driver, but it wasn't an "accepted answer" so I'd rather not take a chance on it. Also I'll admit I'm a bit lost on that and would like help doing so with the specific information I've given.

xev shows that no internal event is triggered for my wireless switch (f12), but other function keys also acting as hardware switches work fine. Edit this doesn't matter, since xev shows no event even when the switch is properly working. I'm considering removing this paragraph....

I would be happy to provide more information, so long as you're willing to help me find it for you! This is a very annoying bug.

I have a Compaq Presario CQ62.

Edit. I just tried to reload bios defaults (or something) as shown by this video. Didn't work.

Edit. I tried the contents of this answer, and it didn't work.

Edit. Output of lspci | grep Network:

02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Edit. Pastebins of more lengthy outputs are given below in the comments.

Edit. I don't know if I'm right, but I found this line in dmesg:

[    0.198949] acpi PNP0A08:00: ACPI _OSC support notification failed, disabling PCIe ASPM

which seems like it might be something, since it refers to PCI.... I'm a noob who's trying my best!

Edit. This? From dmesg? It has the name ath and phy0 which relates to the driver and one of the network interfaces (as far as I know).

[  106.592792] ath: phy0: ASPM enabled: 0x43

Edit. This morning, I had had the laptop suspended all night, and then when I tried to awake it, it simply wouldn't. It would try, and then it would sleep again (I guess it felt a little bit like me! </badjoke>). Is it possible these problems are related?

  • Will the Ubuntu developers solve this problem in the near future do you think?
    – blaineh
    Oct 24, 2013 at 19:38
  • What is the result of: sudo rfkill unblock 0? How about: sudo rfkill unblock 1?
    – chili555
    Oct 24, 2013 at 22:15
  • Tried it, no effect I'm afraid :/
    – blaineh
    Oct 24, 2013 at 23:22
  • How about: sudo modprobe -r hp-wmi && sudo rfkill unblock all? If it helps, we can make it permanent.
    – chili555
    Oct 24, 2013 at 23:33
  • No effect :/ This is a super annoying bug!!
    – blaineh
    Oct 25, 2013 at 2:29

2 Answers 2


Well, I had installed Ubuntu 13.10 on a new machine but messed my network setting up.

  1. I installed gksu
  2. I ran

    gksu gedit /etc/network/interfaces
  3. Edit the file with:

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    # The loopback network interface
    auto lo
    iface lo inet loopback
    # This is a list of hotpluggable network interfaces.
    # They will be activated automatically by the hotplug subsystem.
    # auto eth1
    # iface eth1 inet dhcp

    then just save it.

  4. Just to make sure everything is ok

    please check your dhcpd.conf file found in /etc/dhcp/dhcpd.conf to make sure

    option domain-name "example.org";
    option domain-name-server ns1.example.org, ns2.example.org;
    default-lease-time 600;
    max-lease-time 7200;

    do not have # before them.

  5. Now restart your system and I hope it works just like mine did.

  • I would upvote you, since it seems this is a good answer, but an update solved it!
    – blaineh
    Nov 26, 2013 at 3:21

LITERALLY, an update today took care of the problem. Sorry I can't be more helpful to any future sufferers of this problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.