So, interesting problem.

What I have done:

I click the sound indicator and adjust the volume with no problems. I can use the sound keys on my keyboard and it works without an issue. I can adjust and manipulate the sound in any fashion and it works. However, the indicator itself (speaker looking icon) will not show changes. Such as, if I press mute, it will indeed mute, but the icon will not show an "X", but the sound level will be all the way down, will indicate a red-X Speaker notification.

The slider will change based on how I adjust the sound, but the speaker icon will not lose it's "rings" (little vertical lines to the right of speaker icon).

What I know

I know there has been a recognized bug in Lubuntu XFCE that the indicator does not work, but the issues I am having are not like theirs. My sound operates as it should, the Unity Indicator is not.

What I have done

I have tried some quick fixes I have seen to no avail they are:

editing usr/share/dbus-1/services/indicator-sound.service and changing





Just wanted to indicate in case someone is blindly changing files thinking I found a fix.

Any help?


To make things more interesting, the indicator works 100% as it should on the login screen but not once I log in.

Output of sudo dpkg -l | grep indicator:

ii  gir1.2-appindicator3-0.1                  12.10.1+13.10.20130920-0ubuntu2         amd64        Typelib files for libappindicator3-1.
ii  gir1.2-syncmenu-0.1                       12.10.5+13.10.20131011-0ubuntu1         amd64        indicator for synchronisation processes status - bindings
ii  indicator-application                     12.10.1daily13.01.25-0ubuntu1           amd64        Application Indicators
ii  indicator-appmenu                         13.01.0+13.10.20130930-0ubuntu1         amd64        Indicator for application menus.
ii  indicator-bluetooth                       0.0.6+13.10.20131016-0ubuntu1           amd64        System bluetooth indicator.
ii  indicator-cpufreq                         0.2.2-0ubuntu1                          all          CPU frequency scaling indicator
ii  indicator-datetime                        13.10.0+13.10.20131016.2-0ubuntu1       amd64        Simple clock
ii  indicator-keyboard                        0.0.0+13.10.20131010.1-0ubuntu1         amd64        Keyboard indicator
ii  indicator-messages                        13.10.1+13.10.20131011-0ubuntu1         amd64        indicator that collects messages that need a response
ii  indicator-multiload                       0.3-0ubuntu1                            amd64        Graphical system load indicator for CPU, ram, etc.
ii  indicator-power                           12.10.6+13.10.20131008-0ubuntu1         amd64        Indicator showing power state.
ii  indicator-printers                        0.1.7daily13.03.01-0ubuntu1             amd64        indicator showing active print jobs
ii  indicator-session                         12.10.5+13.10.20131004-0ubuntu1         amd64        indicator showing session management, status and user switching
ii  indicator-sound                           12.10.2+13.10.20131011-0ubuntu1         amd64        System sound indicator.
ii  indicator-sound-gtk2                                  amd64        System sound indicator.
ii  indicator-sync                            12.10.5+13.10.20131011-0ubuntu1         amd64        indicator for synchronisation processes status
ii  indicator-sysmonitor                      0.4.3                                   all          System Monitor Indicator
rc  indicator-weather                         13.7.1                                  all          indicator that displays weather information
ii  libappindicator3-1                        12.10.1+13.10.20130920-0ubuntu2         amd64        Application Indicators
ii  libindicator3-7                           12.10.2+13.10.20130913-0ubuntu1         amd64        panel indicator applet - shared library
ii  libindicator7                             12.10.2+13.10.20130913-0ubuntu1         amd64        panel indicator applet - shared library
ii  libsync-menu1:amd64                       12.10.5+13.10.20131011-0ubuntu1         amd64        indicator for synchronisation processes status - libraries
ii  my-weather-indicator                      0.6.5-0extras13.04.2                    all          Get weather information for your town with My-Weather-Indicator
ii  sni-qt:amd64                              0.2.6-0ubuntu1                          amd64        indicator support for Qt
ii  telepathy-indicator                       0.3.1daily13.06.19-0ubuntu1             amd64        Desktop service to integrate Telepathy with the messaging menu.
  • 1
    This time try to change your sound using commands and check whether your icon vertical line changes or not. To decrease the volume by 25% execute this :amixer -q sset Master 25%-. Execute 2-3 times same command when volume is full(100%). Also to increase the volume by 25% execute this: amixer -q sset Master 25%+ Oct 24, 2013 at 18:43
  • @SauravKumar Same results, sound does change, verticle lines/speaker icon do not change.
    – cbennett
    Oct 24, 2013 at 19:09
  • Ok, try to re-configure once by: sudo dpkg-reconfigure indicator-sound and logout/login or restart. If it still doesn't help then once try to re-install by: sudo apt-get -f install --reinstall indicator-sound and again logout/login or restart. Reply.. Oct 24, 2013 at 19:12
  • Now I have no sound indicator what-so-ever even after reinstalling... EDIT: Restarted, now all it shows in the grayed out muted icon
    – cbennett
    Oct 24, 2013 at 19:16
  • EDIT 2: Logged in and out, once again missing sound icon...
    – cbennett
    Oct 24, 2013 at 19:21

1 Answer 1



I had found a solution to the problem. I had to reinstall Alsa and Pulse Audio and it corrected all of my problems. A detailed explanation of how to do this can be found here:


  • I was thinking that there is a problem in the indicator applet. Good to know finally you did it. Although I recommend you to mention the basic steps needed. It will help on the case when the link will be delete or broken. :) Oct 24, 2013 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.