UPDATE: Because Apache 2.4 is the default version (instead of the previous 2.2) this error occurs. However as can be seen here all future versions of Ubuntu 13.10 and above will not support this package until it gets fixed upstream. As a work around you do not need to install this package as it is only required for Apache authentication against MySQL (as opposed to doing it at the web app end, which is far more common)

I'm trying to install my LAMP environment on Ubuntu 13.10 using my script file that can be found here. That script worked for Ubuntu 12.04, Ubuntu 13.04 but when I try it on Ubuntu 13.10 it gives the following error:

   E: Package 'libapache2-mod-auth-mysql' has no installation candidate

Any idea on how to fix this? Note, I do want this package to be installed.

EDIT: I've found out now that the reason this could not be installed was because it needed the following two packages that were missing: libmysqlclient16 and apache2.2-common. Do I just need to install these packages or were they removed for a reason?

closed as off-topic by Braiam, chaskes, Eric Carvalho, Warren Hill, Seth Nov 4 '13 at 18:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, chaskes, Eric Carvalho, Warren Hill, Seth
If this question can be reworded to fit the rules in the help center, please edit the question.


It looks like there's a bug logged for this.


  • Thanks for the update. Just a quick question, when/if they fix this bug (I'm hoping they do fix it as setting up a LAMP environment is pretty damn important imho), how do I get this "updated" code? Do I just need to run a "sudo apt-get update"? – John Crawford Oct 25 '13 at 8:16
  • @JohnCrawford: Provided they uploaded their patch into official repositories, then yes. – phresnel Sep 15 '14 at 5:35

I tried to install it manually by downloading deb package from: https://launchpad.net/ubuntu/saucy/amd64/libapache2-mod-auth-mysql/4.3.9-13.1ubuntu1

But libapache2-mod-auth-mysql depends on apache2.2-common: https://launchpad.net/ubuntu/saucy/amd64/apache2.2-common/2.2.22-6ubuntu5

And apache2.2-common depends on apache2.2-bin: https://launchpad.net/ubuntu/saucy/amd64/apache2.2-bin/2.4.6-2ubuntu2

Apache2.2-bin has no dependencies, but to install it you have to remove gnome-user-share. Gnome user share is needed to share over bluetooth and WebDAV. Probably this incompatibility is the reason why installing libapache2-mod-auth-mysql has been disabled.

After removing gnome-user-share I've managed to install apache2.2-bin, but apache2.2-common breaks in conflict with apache2-bin which is needed by apache2.2-bin. It is blocked this way and I didn't find any solution to that problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.