5

i'm running ubuntu 12.04.3 x86 desktop in my corporation environment. I join the corp domain by Likewise open. But when I ping another pc, say hostname is pc-test, "ping pc-test" or "ping pc-test.domain.name" returns slow interval (about 5 seconds) but the ping value is below 1 ms. When I use "ping -n pc-test", everything works well. So I conclude this is about reverse DNS issue.

how to fix this issue? many thanks!

Edit: In my understanding, reverse DNS issue is related to DNS server or Wins server, not only an ubuntu issue, is this right?

if I wanna fix this issue as much as possible on ubuntu but not on network servers, what to do?

  • In addition to the answers have a look at your /etc/resolv.conf A wrong nameserver entry will cause a long delay (like seconds) but fast ping (like milli seconds). – Jonas Stein Dec 13 '14 at 13:10
6

To elaborate on Franky's answer, this is quite likely a problem with the configuration of /etc/nsswitch.conf.

tl;dr: Change the line hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4 in /etc/nsswitch.conf to hosts: files dns

There is a line in /etc/nsswitch.conf named "hosts:" that determines how your computer will resolve hostnames into IP addresses. (Read more about this process here: https://help.ubuntu.com/10.04/serverguide/network-configuration.html) This line is where the problem most likely is.

By default Ubuntu first checks the host file to see if the hostname has been manually specified there, and then it runs a minimal Multicast DNS query (this is used in zeroconf environments, Wikipedia has an article on it here https://en.wikipedia.org/wiki/Multicast_DNS if you want to learn more), followed by a regular dns query, and then finally a full Multicast DNS query.

In corporate environments that don't have reverse DNS set up properly (which apparently is often the case) the Multicast DNS queries cause major slowdowns. To fix the problem you should either fix reverse DNS or remove the Multicast DNS queries from the configuration. Given that in a corporate environment you likely have a DNS server of your own, I'd recommend just getting rid of the Multicast DNS query option from the configuration.

See https://bugs.launchpad.net/ubuntu/+source/nss-mdns/+bug/94940 for more information about this problem.

0

Goto https://bbs.archlinux.org/viewtopic.php?id=58712 and try the solution given by "wonder" It worked for me.

  • 3
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Braiam Nov 11 '13 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.