Here's my setup:

  • Lenovo ThinkPad T420, brand new
  • NVIDIA Graphics Card
  • 4GB of Ram
  • 128GB Solid State Drive
  • Intel Core i5 Processor

Given these specs, there's no reason games and Unity shouldn't be working. The strange thing is that both do work when I run from a live USB, but not when Ubuntu is installed to the hard drive. Is there something different with the 3D capabilities of running from the computer as opposed to running from the live USB?

Edit: Some more information: When I log in for the first time when running from the hard drive, Ubuntu says "It seems that you do not have the hardware required to run Unity. Please choose Ubuntu Classic at the login screen and you will be using the traditional environment."

  • Also had this same issue. I also disabled the Nvidia driver and was able to get unity to run.
    – user15047
    Apr 26 '11 at 16:55

I was having the same problem and I have found a simple solution. The "problem" appears to be that the nvidia driver does not support hybrid graphics cards, or NVIDIA Optimus.

If you go into the bios and turn off Optimus and force the system to use the discrete graphics card, unity will work and X will perform much better. (note: you will be sacrificing battery life)

(oops this is the Christian K from the other answer. Ignore that answer.)

  • This describes my problem much better. I did that, and Unity and games worked lightning-fast!... until I unplugged the laptop. Then the computer crashed. This happens every time I try it, and it also happens every time I try to log in on battery power. May 4 '11 at 21:08

Hybrid graphics has improved a bit lately. Have a look at this websites for bumblebee: https://launchpad.net/~hybrid-graphics-linux


I had the same issue, no Unity on a Lenovo T420 with a card Nvidia NVS 4200M (Optimus). Here is how to work around it: In the BIOS (press F1 at startup), under Config > Graphics, you got 3 choices:

  • Integrated (Intel HD 3000)
  • Optimus (Intel HD 3000 + NVS 4200M)
  • Discrete (NVS 4200M).

If you choose Discrete and Save, the Nvidia drivier is used and you get Unity. Fast performance, bad power usage.

Or if you delete the Nvidia driver in Ubuntu, then in the BIOS choose Integrated, the Intel driver is used and you get Unity. Less performance, better power usage.

The issue is that with the 3rd option, Optimus, the nouveau driver is used, doesn't know which card to use, and end up disabling the 3D acceleration, which kills Unity (in Ubuntu 11.10, you would get Unity-2D instead).

In the BIOS of the T420, in Config > Graphics, there is also an option to force the use of the discrete card instead of Optimus if the OS does not support it. Unfortunately this doesn't work, even when enabled, Optimus is used. (Tested with dualboot using BOOTMGR booting Grub2. Can someone confirm with Ubuntu and Grub2 only?)

There is a bug for this:

There is a project to support Optimus for Linux:

The mailing list for group:

suggest that it is already working.

  • kenden - is this an Answer to the original question? If it is not an Answer, please create your own question and delete this answer.
    – fossfreedom
    May 23 '11 at 19:21

In additional to selecting the discrete graphics (or integrated graphics) instead of hybrid you also have to turn off the OS detection of the graphics. Those two should force you to the discrete or integrated graphics only.


Have you tried installing the restricted driver from Nvidia via terminal window?

  1. Go to Control pannel aka "System Settings"
  2. Select "additional drivers"
  3. Select the Nvidia driver

To install latest -

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get install nvidia-current

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.