I have to become dependant on Autokey phrases to insert all kind of repetitive data. It was working fine when I upgraded from to 13.10 without formatting. However, I wanted to get rid of the clutter and unused junk and made a clean —read formatting- install. After installation and reconfiguration of Autokey it displays an odd but consistent behaviour.

a) Saving a new modification hangs the program. The window goes grey and I have to close it by means of a terminal.

b) Phrases configured to trigger without a key are not working. Neither with a key trigger.

c) A trigger key to show the window doesn't work.

d) The program is configured to start at login and show an icon on panel. Neither function works.

I've installed and reinstalled both versions (KDE and GTK) several times. None works OK.

What really puzzles me is that it was working quite fine in Saucy just prior to my reinstall.

Has anyone experienced anything like this? I really need a macro expander. Can anyone suggest an alternative?

Thanks in advance!


Edit: Diving the net I've found two things:

1) Autokey is basically unusable with Saucy -at least within Unity- and...

2) It seems to have ceased developement since a year and a half ago. Thus, I NEED a replacement that works. Any input to that effect much appreciated. Anything that will insert my email or my access ID to some sites will do. TIA.


Edit #2: Managed to get Autokey KDE working. How? I'm not truly sure. I installed it alongside Autokey QT and it worked. In the process, it (or maybe me) managed to mess up a lot of my home folder permissions which I had to fix (chmod -R) manually. It also broke Unity and lightdm which I had to restart from the command line. However, it's been working fine since then. The only gripe is that I haven't managed to make it autostart at log-in but that's minor. I'm probably not pointing the correct command to the autostart roster.

Closing the question.

  • I've had this problem for a long time (already in 12.10) too and I haven't found any way to make Autokey work properly. It seems however that it was working for you after the upgrade to 13.10 but stopped when you made a fresh install. It could mean that the problem lies in the configuration. Have you kept a backup of the old profile? It would be interesting to compare. One alternative is IronAHK, but I haven't tried myself. – Aurelien Nov 2 '13 at 11:54
  • Aurelien, sorry for the late reply. Out of town. I thought I had a backup of this as I backed up all my home directory but -alas- no. I'll check IronAHK. Thanks for the heads up. – Jorge M. Treviño Nov 7 '13 at 1:35
  • It's getting stranger. Last night I installed AutoKey (KDE) and then removed Autokey GTK. It started working. For some reason the new installation messed up the permissions of some of my folders, which I had to restore manually. It is still working with some quirks like sometimes I have to quit it and re-fire it from the menu to get it to accept input. I haven't been able to make it autostart either. I don't consider this is a real solution so I will leave the question open until I can iron the quirks. – Jorge M. Treviño Nov 7 '13 at 18:07

I had a similar problem.

It seems that having a blank 'abbreviation' enabled will cause autokey to behave erratically.

Deleting this extra blank 'abbreviation' seems to restore Autokey to an operable state.

  • 1
    Not exactly my case. I found that autokey-qt [Autokey (KDE)] works fine. I uninstalled and then purged every thing with "autokey" in it, then reinstaled Autokey (KDE) from the Software Center. The problem i'm facing right now on a different system is that it installed itself with root ownership and cannot edit the macro files. Otherwise it works OK. – Jorge M. Treviño Jan 18 '14 at 4:58
  • interesting; so you cannot run the program as a normal user or just the scripts? Also, the problem I described was with autokey-qt but seemed likely that it might also occur in the gtk version. – virtualxtc Jan 18 '14 at 8:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.