7

I have a mac that is running a dual boot with OSX and Ubuntu. I am using rEFIT. I just updated my OSX to the new OSX Mavericks, but when i restarted my computer and tried to enter Ubuntu from rEFIT I just got an error message saying error: unknown filesystem.

How can I solve this? Where is the problem, is it GRUB or rEFIT?

5

After a lot of searching for solutions, I also found myself in similar situation. AndrewM's solution did not work for me either. The Mac is on pure EFI (non-hybrid), pure 64 bit Linux.

A couple points to make: 1) There are two projects, rEFIt and rEFInd. 2) You can install both and I have found that they will detect each other and let you boot one from the other.

Here is what finally got me back into Linux after Mavericks upgrade... Download the latest rEFind http://www.rodsbooks.com/refind/ (currently 0.7.4) and issue this command from OS X:

sudo ./install.sh --alldrivers

I ended up with a long menu of all my Linux kernels and was able to boot directly into Ubuntu / Debian without GRUB menu. Now at least I can get into Linux and rework the GRUB and look at EFI configurations.

1

I had the same issue. I removed refit and installed rEFind. Refit is not actively maintained. None the less with each mac os update there would be chances that you would have to reinstall refind.

0

I had a similar problem but when I tried to launch Ubuntu it came up with something along the lines of "please insert boot disk".

I fixed the problem by restarting my computer and when the rEFIT screen comes up launch the "Start Partition Tool". For me it said "MBR table must be updated". I had to press "y" to update it. After I updated it I had to boot into Mavericks and restart it again but then launching Ubuntu Linux worked fine. Hope this works for you!

1
  • 1
    Thats what I also tried to do first, however it didn't help. Oct 25 '13 at 6:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.