64

I recently installed Saucy Salamander on my computer. Previously in Ringtail, Super+D used to show the desktop. However for this release, the Super+D does not seem to work properly... Is it a bug?

  • 13
    The shortcut is Ctrl + Super + D. – Aditya Oct 23 '13 at 14:17
95

Super + D doesn't work starting with Ubuntu 13.10. Use Ctrl + Super + D instead, I tested it and it works.

How to change the keys:

Open the Dash and type keyboard. There should be an app called Keyboard. Click on it and then go to the Shortcuts tab. Click on the Navigation list entry and scroll down until you see Hide all normal windows, click on it and create a new shortcut, for example:

Super + D

And that's it, you're done.

|improve this answer|||||
  • 9
    I did that and super + D doesn't work more than once. Ctrl + Super + D works as expected, and it's interesting, once I'm in the desktop after I pressed Ctrl + Super + D, Super + D works. I am on ubuntu 14.04 – Akronix May 15 '14 at 23:23
  • 15
    Fixed!! It has to be changed in the compiz settings into the unity plugin. These are the steps: install compizconfig-settings-manager, go to ubuntu unity plugin, and change the entry of "Show desktop" for what you want. It asked me that super + D was already taken for other shortcut (which did also show desktop), so I chose to proceed anyway. – Akronix May 15 '14 at 23:36
  • 2
    Start with 13.10? Well I'm on 12.04 LTS and it doesn't work. – Samir May 28 '14 at 20:14
  • @Akronix Your tip is helping me for the last 2 years now. Still timely on Ubuntu 16.04. – Rav Sep 10 '16 at 18:48
41

It is not a bug. In order to make Super+D shortcut to work you must to go to System SettingsAppearance, select Behavior tab and tick And show desktop icon to the launcher:

Appearance - Behavior

If you don't like to have the desktop icon on your launcher, then use Ctrl+Super+D shortcut.

Or you can use Alt+Tab to switch to desktop:

enter image description here

|improve this answer|||||
  • 3
    Thanks, you saved me! Who on earth has implemented it in this strange way!? – linusg Sep 7 '16 at 15:40
10

With the CompizConfig Settings Manager, you can enable the Super + D shortcut to show desktop without having that annoying icon in the launcher.

Just open CompizConfig and go to Desktop >> Ubuntu Unity Plugin >> General and change the show desktop shortcut. Show Desktop shortcut config In the Switcher tab there, you can also disable having the Desktop icon in the Alt-Tab menu.

|improve this answer|||||
3

I've experienced the same issue with Ubuntu 17.04, but managed to fix it by following the instructions suggested by Akronix.

The steps are as follows:

  1. Install CompizConfig Settings Manager by typing

    sudo apt-get install compizconfig-settings-manager
    
  2. Run the manager, type "unity" in the Filter text field and select Ubuntu Unity Plugin
  3. Find Show Desktop in the list and update it with the desired combination

Thanks to Akronix for finding the solution.

|improve this answer|||||
2

For 11.10 and 12.10

Control-Alt-D shows the desktop for me

For 12.04 ,13.04 and 14.04

Control-Super-D works for me

|improve this answer|||||
1

The official hotkey to show desktop in Ubuntu is Ctrl + Super + D. But if you want to use Super+D, you can try my steps:
1. Open dconf Editor
2. Go to com => canonical => unity => launcher.
3. Click on favorites's value column and go to eol
4. Add , 'unity://desktop-icon' before ].

Now you see Show Desktop shortcut on Unity Launcher. In the future, you can use Super+D to show desktop.

|improve this answer|||||
  • 1
    This has already been answered before in a much easier method by Radu Rădeanu. – simbadub23 Oct 23 '13 at 15:36
1

Ubuntu 18.04 L.T.S.

Go to SettingsDevicesKeyboardNavigation section.

Click "Hide all normal windows" which is probably set to "disabled". Enter your new keyboard shortcut, which I set to Ctrl+Alt+D.

Voila! Instant desktop!

|improve this answer|||||
0

1 - System Settings → Appearance

2 - enter image description here

3 - run on command: gsettings get com.canonical.Unity.Launcher favorites

4 - copy the given list and delete 'unity://desktop-icon'

5 - run on command: gsettings set com.canonical.Unity.Launcher favorites [GIVEN LIST WITHOUT 'unity://desktop-icon']

6 - CompizConfig → General Options → Key Bindings

7 - Set "Show desktop" shortcut

Cheers.

|improve this answer|||||
0

Rephrasing @Radu Rădeanu's answer,

Step 1: Change the shortcut to Super + D in settings->keyboard->shortcuts->Navigation->"Hide all normal windows.

Step 2: Go to Settings->Appearance->Behavior, tick Add show desktop icon to launcher.

Now it defenitly works

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.