Not sure what has happened to my Ubuntu 13.04 server. It is pretty much a LAMP & SAMBA server only, no other apps installed, no shell, command line only.

I run an apt-get update a fortnight ago and it all worked fine. Today I notice another set of updates available so I try again, and I keep getting stuck at:

Hit http://security.ubuntu.com precise-security/universe Translation-en
100% [Waiting for headers]

Every time it stops there. Letting it go for a while it eventually gives the message

Err http://au.archive.ubuntu.com precise-updates Release.gpg
  Connection failed

I tried solutions from the following article (and the links in it) but I have not fixed the issue:

apt-get update very slow, stuck at “Waiting for headers”

I live in Australia and my Internet speed test is showing 500Kbps right now. Any suggestions are really welcome.

Thanks in advance!


1 Answer 1


This might be a temporary problem with the mirror. I also can't reach the mirror at the moment of writing. Launchpad lists mirrors in Australia. Most of them are in a good shape and you could also choose them. The Ubuntu Wiki also has a page on Australian apt mirrors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.