When trying to mount an exfat filesystem, I get the following error:

Error mounting /dev/sda6 at /media/gkp/Backup: Command-line 
`mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda6" "/media/gkp/Backup"' 
exited with non-zero exit status 32: mount: unknown filesystem type 'exfat'

Exfat is used on some USB sticks and camera sd cards. What can I do to mount this type of filesystem?


2 Answers 2


You get this error because the exfat filesystem is not installed in Ubuntu by default. exFAT is proprietary and patented by Microsoft.

Ubuntu 13.10 or higher

Since Ubuntu 13.10, this package is in the main repository. Just install exfat-fuse and exfat-utils:

sudo apt update && sudo apt install exfat-fuse exfat-utils

Ubuntu 12.04

For ubuntu 13.04 and lower, you'll need a ppa to install the exfat support. Installation procedure:

sudo apt-add-repository ppa:relan/exfat
sudo apt-get update
sudo apt-get install fuse-exfat

If you see the error gpg: "tag:launchpad.net:2008:redacted" not a key ID: skipping during the apt-add-repository step, then you'll need to manually install the signing key and run the apt-get update and apt-get install steps after that:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4DF9B28CA252A784


  • 4
    looks like for 13.10 you don't even need the ppa it's just sudo apt-get install exfat-fuse ref: askubuntu.com/a/85459/20972
    – rogerdpack
    Jan 6, 2014 at 14:48
  • 1
    :) and after then sudo ntfsfix /dev/sdb1 help me to get mount. wait for few second it could time to mount.
    – CoDe
    Apr 3, 2014 at 10:51
  • 3
    +1. On Ubuntu 14.04, no PPA is needed. I was able to sudo apt-get install exfat-fuse and, after installation, my 64GB SD CARD mounted as soon as I plugged it in. Jun 11, 2014 at 18:38
  • 4
    sudo apt-get install exfat-fuse exfat-utils Works on 16.04!
    – Potaito
    May 25, 2016 at 14:22
  • 10
    And now 18.04, still good. Yay! = sudo apt install exfat-fuse exfat-utils
    – Dɑvïd
    Jun 13, 2018 at 9:30

As of November 25, 2019, this does not work yet in Ubuntu 19.10 Eoan, probably because apt just cannot grab exfat-fuse. I fixed this problem by downloading exfat-fuse deb directly. This is after installing a dependency.

  • This worked, thankyou!
    – JMK
    Dec 2, 2019 at 18:04
  • 2
    As of Dec 11, it does seem to fetch exfat-fuse properly.
    – pspahn
    Dec 11, 2019 at 23:49
  • Ubuntu 20.04 installing exfat-fuse and exfat-utils works. Yet I have this error FUSE exfat 1.3.0 ERROR: failed to read boot sector. Nov 2, 2020 at 22:40
  • This is either because your device wasn't set up correctly, or could also be because your exfat device is somehow 'not good' e.g. corrupt, full, or physically malfunctioning. Try with another device you've worked with before and if that works then try remake the failed device
    – kana
    Nov 3, 2020 at 0:51
  • Upgraded to 20.10, installed exfatprogs. Mounting works randomly. Moreover, if the card is inserted directly (is SD slot of Macbookpro), it is always read-only. If it is connected through a card reader, write is possible. Nov 5, 2020 at 21:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.