I've got a PDF document that I would like to be able to read... but for some reason a number of the embedded pictures and graphs don't display cleanly when opened in evince or okular on Ubuntu 13.04 (they display normally in Adobe Acrobat Reader on Windows 7). I've tried downloading and installing Adobe Acrobat Reader 9.5 and FoxIt Reader 1.1 in .deb format and get warnings about bad packaging format, etc. Even when I click thru to install anyway, the install process would hang up over and over again.

Are there any other viable options out there?

Just for reference, here is a download link for the offending file if anyone cares to test it on their machine (warning - 67+MB file):

EPRI Power System Dynamics Tutorial

3 Answers 3


I can confirm the issue on Ubuntu 12.04 with Evince 3.4.0 installed. Given how this occurs both under Evince and Okular it's likely an issue with the PDF backend, libpoppler. You might want to report a bug and link to the sample file. That's the only surefire way to get this fixed.

As a workaround I would advise to use Chrome's inbuilt (and proprietary) PDF viewer. Also, you should be able to install Adobe Reader from the Ubuntu Software Center. It should take care of all the dependency issues automatically.

  • I'm not seeing any entry for Adobe Acrobat Reader in the Software Center, and when I download it directly from Adobe's site (in .deb format) it generates errors about bad packaging - wrong uid, etc. Is it possible to open an already downloaded PDF in Chrome (or Chromium) like mentioned below for Firefox?
    – memilanuk
    Oct 23, 2013 at 9:26
  • I looked into filing a bug report against poppler w/ the cairo backend (which is what evince reports)... looks like there already is one, just need an updated version of poppler. bugs.freedesktop.org/show_bug.cgi?id=70085
    – memilanuk
    Oct 23, 2013 at 9:40
  • @memilanuk I am not quite sure - because it has been a while - but I think you have to activate the "partners" repository first. Acrobat reader should appear in the USC after that. Alternatively you could try installing it from the CLI with sudo apt-get install acroread. As far as the web browsers are concerned: Yes, with Chrome you can just drag your local PDF file to a tab and it should open it in Chrome's inbuilt PDF viewer. I suppose the same method would work with FF as well. Oct 23, 2013 at 16:58
  • @memilanuk Also if you decide to upgrade poppler and still experience the same issues you should definitely look into reporting a bug of your own. Oftentimes patches that might fix rendering in one sample file won't translate to others because the underlying issue is completely different. Oct 23, 2013 at 17:01
  • Ah. Guess I didn't have the 'partners' repo enabled... now I have Adobe Reader installed, and everything displays as it should. Thanks!
    – memilanuk
    Oct 24, 2013 at 4:28

If you are using Firefox, what happens if you drag and drop the pdf in the browser? (Firefox has a builtin pdf viewer)

  • I knew FF had a built-in PDF viewer (pdf.js) for files from the web, but I didn't realize I could drag-n-drop a file from my desktop into a FF window and view them that way... sweet!
    – memilanuk
    Oct 23, 2013 at 9:24

I tried to open your file with Evince and embedded graphics are not display clearly. But it did not happen with Foxit Reader 6 on Wine. So this is a bug of Evince. Don't worry!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .