7

I updated from 13.04 to 13.10 but uname -r still says I am on 3.8.0-31-generic. How can i fix this and get 3.11 or 3.12 ?

  • open terminal and try this > sudo apt-get update && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y – Qasim Oct 23 '13 at 3:32
8

Happened exactly the same, I noticed that now that I had to compile wacom drivers. For whichever reason, the package linux-image-generic was not installed (probably ocurred during the upgrade from 13.04 to 13.10).

sudo apt-get install linux-image-generic 

seems to correct the fact (will modify this if not).

You can also do

sudo apt-get install linux-generic 

to automatically install the kernel headers, too (thanks to Lars Nyström).

(obviously if you have -rt or -lowlatency kernels you have to adapt this to your case)

  • 1
    You could also install linux-generic, which will give you both linux-image-generic and linux-headers-generic (askubuntu.com/a/197615/162987). I just installed linux-generic and it worked liked a charm! – Lars Nyström Dec 7 '13 at 20:54
0

Fixed.

I downloaded the 3.12 rc6 kernel deb files from kernel.ubuntu.com and installed it with dpkg -i

  • This works, but still is not a fix: you need to upgrade kernels by hand afterward. My solution will put you back on the automatic kernel updates... – Rmano Dec 12 '13 at 17:07
0

You need to first enable the proposed repositories

enter image description here

enter image description here

Then enable all 4 update sources and on the Ubuntu Software tab enable all 4 options also. Then update and you should see the 3.11.X

enter image description here

Do not update to the 3.12.X or the 3.13.X without knowing that you will find weird behaviors related to drivers, boot time and graphical issues. Always use the one in the updates by Ubuntu.

  • 1
    Kernel 3.11 is standard in 13.10, I think. I have that kernel without need the "proposed"repository. What happened is that during the 13.04->13.10 upgrade the "linux-generic" metapackage was not updated, and the kernel stayed at 3.8. – Rmano Dec 12 '13 at 17:27
  • That is totally correct Rmano. In my case the 2 computers I have here had the same issue and it was solved by doing the steps above. Of course this was for me. Your answer is simpler. – Luis Alvarado Dec 12 '13 at 19:21
  • 1
    Seems like a bug in the 13.04->13.10 upgrade procedure... – Rmano Dec 12 '13 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.