27

I can't find how to enable the line numbers, current line highlight, and other goodness in 13.10.

enter image description here

1
  • 2
    This feature is not removed, besides where is your preferences option in edit menu? Surprising! – simbadub23 Oct 23 '13 at 2:38
16

If you've removed indicator-appmenu to remove global menus then either

  1. Reinstall indicator-appmenu or

  2. run this command (one long line):

    gsettings set org.gnome.settings-daemon.plugins.xsettings overrides '@a{sv} {"Gtk/ShellShowsAppMenu": <int32 0>}'
    

    (If the above doesn't copy as a single line, this code box here will work).

If you've edited gedit.desktop to add an env to keep menus in their window then remove the env, typically env UBUNTU_MENUPROXY=.

As an aside: if one wanted the app menu present in a root nautilus browser then removing indicator-appmenu and running the above from a root prompt will achieve that.

Example:

sudo -i
gsettings set org.gnome.settings-daemon.plugins.xsettings overrides '@a{sv} {"Gtk/ShellShowsAppMenu": <int32 0>}'
4
  • I had not removed indicator-appmenu. But gsettings set org.gnome.settings-daemon.plugins.xsettings overrides '@a{sv} {"Gtk/ShellShowsAppMenu": <int32 0>}' worked immediately. – wim Oct 24 '13 at 13:19
  • That doesn't seem to change anything for me -- and I had removed indicator-appmenu. – Amanda Nov 10 '13 at 22:38
  • 1
    I can assure you that in 13.10/14.04 ubuntu session that it works fine, easily demonstrated. You can just use gsettings or dconf-editor, otherwise post in ubuntu forums & we'll see if it can be squared up for you – doug Nov 11 '13 at 0:34
  • I installed and used dconf-editor. The settings are in org.gnome.gedit.preferences.editor – Moshe May 4 '15 at 12:09
30

It should be there in the Edit, Preferences dialog!

enter image description here

And this is gedit version 3.8.3


There has been a similar issue reported over at ubuntuforums.org. The problem apparently arose when Unity's global menu was removed (by sudo apt-get remove indicator-appmenu). The solution involves using dconf editor to restore menu items or restoring the global menu.

1
  • 3
    I have 3.8.3 but don't have the preferences under Edit menu – wim Oct 23 '13 at 2:21
15

I'm not sure if this is specific to gnome users, but I was able to get to the preferences by clicking up the top, like this:

enter image description here

1
  • The answer that helped me. – Git Gud Apr 23 '19 at 13:46
4
  1. The fastest way to enable/disable displaying line numbers in Gedit is by clicking the downward pointing triangle ▾ in the lower right corner of Gedit where it shows LnXX, ColXX to show the dropdown menu in the below screenshot.

    enter image description here

  2. Check/uncheck the Display line numbers checkbox to toggle displaying line numbers. This action is temporary. It will not display line numbers the next time you open Gedit, so you can use this feature to quickly show the line numbers to find a line in a text file without permanently changing Gedit's preferences for all files.

    If there are files open in multiple tabs in Gedit, checking the Display line numbers checkbox will only affect the file in the tab that has the focus. This action will not affect the files that are open in other tabs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.