1

It doesn't matter where, it just won't save any files. I have tried running gksudo gedit /etc/default/grub, because I am trying to change the quiet splash to elevator=deadline but when I try to save it, "Permission Denied"

When I type gksudo gedit /etc/default/grub, it prompts me for a password, then nothing opens. What should I do?

2

Well, normally you don't have permissions to modify /etc/default/grub, but you can do it with root privileges:

sudo -i                   #to get root permissions
gedit /etc/default/grub   #to edit /etc/default/grub

If your gedit still doesn't open, try to reinstall it (using sudo apt-get install --reinstall gedit command) or use nano instead (nano /etc/default/grub).

  • The gksudo gedit /etc/default/grub should imply he is getting the permission to edit the file. – Dr_Bunsen Oct 22 '13 at 20:39
  • @Dr_Bunsen As you can see, I suggested him to reinstall gedit. – Radu Rădeanu Oct 22 '13 at 20:43
  • 1
    Okay, turns out, Gedit wasn't installed. So I did what you said Radu, as well as installing Gedit and it worked. Thanks for all you help guys and gals :) – user2769752 Oct 22 '13 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.