4

Since I upgraded to 13.10, I cannot export CD tracks in Rhythmbox. It told me "Additional software is required to encode media in your preferred format: Vorbis encoder" I click install, and it loops back and does not work.

I un-installed Rhythmbox, re-installed it, and it still does not work. Now when I click install, I get "Invalid Commandline. The parameters passed to the application had an invalid format. Please file a bug!

The parameters were: --transient-for=65011715 gstreamer|1.0|rhythmbox|Vorbis encoder|encoder-audio/x-vorbis"

I also renamed the rhythmbox folders in ~/.cache and ~/.local - this also made new difference.

Is this a bug, or do I have something set up incorrectly here?

If it makes a difference, I am running on a Dell D630.

4

The message is erroneous & a long standing bug. Vorbis encoding is default enabled & if you just went ahead it would work

To 'fix'

Under Preferences > Music > Format settings choose one of the 3 options, for either constant or varible set a quality.

Then close & re-open RB, the so called error will be gone

enter image description here

after restarting RB the install box will be gone

1

I fixed it by commenting the preset line in the streamprofile-oggvorbix-1 section of the file /usr/share/rhythmbox/rhythmbox.gep :

[streamprofile-oggvorbis-1]
parent = oggvorbis
type = audio

### Comment the following line by adding a # at the beginning of the line.
# preset = Ubuntu

format = audio/x-vorbis
presence = 1
  • Thank you! This actually worked, unlike the other answers. I hope they fix this bug soon. – Serrano Sep 14 '15 at 4:32
0

Try installing vrobis-tool. To install just click vorbis-tool Install comixcursors-lefthanded

  • That did not work - I still get the "Unable to transfer tracks: Additional software is required to encode media in your preferred format:Vorbis encoder". If I click Install, I still get the message above. The debug vorbis-tool version did not give any more information either. – user206097 Oct 24 '13 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.