3

I'm using Rhythmbox 2.99 in Ubuntu 13.10, and when I first launch the application it searches for music and works like a charm, but if I try to launch it later again nothing happens. When I run it in terminal I get this:

$ rhythmbox
(rhythmbox:8860): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid).  Unable to remove object from construction_objects list, so memory was probably just leaked.  Please use GInitable instead. 

Segmentation fault

Any ideas how to make it work again?

The output of sudo dpkg -l | grep rhythmbox:

ii  gir1.2-rb-3.0                          2.99.1-0ubuntu1                         amd64        GObject introspection data for the rhythmbox music player
ii  librhythmbox-core7                     2.99.1-0ubuntu1                         amd64        support library for the rhythmbox music player
ii  rhythmbox                              2.99.1-0ubuntu1                         amd64   music player and organizer for GNOME
ii  rhythmbox-data                         2.99.1-0ubuntu1                         all           data files for rhythmbox
ii  rhythmbox-mozilla                      2.99.1-0ubuntu1                         amd64         Rhythmbox Mozilla plugin
ii  rhythmbox-plugin-cdrecorder            2.99.1-0ubuntu1                         amd64        burning plugin for rhythmbox music player
ii  rhythmbox-plugin-equalizer             0.3-2                                   all          rhythmbox sound equalizer
ii  rhythmbox-plugin-zeitgeist             2.99.1-0ubuntu1                         all          zeitgeist plugin for rhythmbox music player
ii  rhythmbox-plugins                      2.99.1-0ubuntu1                         amd64        plugins for rhythmbox music player
2
  • 1
    Did you close the rhythmbox properly before launching it again? I mean when you start rhythmbox and when you normally close it using alt+F4 or from the window it doesn't close properly. You can close rhythmbox properly by typing this command in terminal pkill rhythmbox. Then try to re-launch again. Reply.. – Saurav Kumar Oct 22 '13 at 10:06
  • That's not the case, because I can't lauch it even after a system restart. – Slaci Oct 22 '13 at 11:57
4

Try these once

  1. First try to re-configure it, if it doesn't help then follow the step 2.

    sudo pkill rhythmbox
    sudo dpkg-reconfigure rhythmbox
    

    Check after Log-out/ Restart.

  2. If first doesn't help then re-install rhythmbox after removing all configuration file:

    sudo apt-get autoremove rhythmbox
    sudo apt-get --purge remove rhythmbox
    sudo find / | grep rhythmbox | sudo xargs rm -rf
    sudo apt-get update && sudo apt-get -f install rhythmbox
    

    Check after Log-out/Restart.

Reply if you get any error at any particular command.

4
  • The first one didn't help, the second one gave a new error in terminal, and the app still doesn't launch, sorry for the bad editing: ~$ rhythmbox rhythmbox: error while loading shared libraries: librhythmbox- core.so.7: cannot open shared object file: No such file or directory – Slaci Oct 22 '13 at 13:40
  • It seems that rhythmbox doesn't install properly, one library file is missing.. You can install it by: sudo apt-get -f install librhythmbox*. If still it gives your error then post the output of this command in your question(not in comment): sudo dpkg -l | grep rhythmbox – Saurav Kumar Oct 22 '13 at 13:51
  • I somehow managed to solve the problem by uninstall, and reinstall completely all the packages that are related to rhythmbox. It works now, but the GUI is english and my system is hungarian, is there a way to change it? – Slaci Oct 23 '13 at 17:45
  • First good to know that you managed to install it. I think you've to install plugins for rhythmbox that you've to search in google or in Synaptic – Saurav Kumar Oct 23 '13 at 18:14
4

Just remove the db file .local/share/rhythmbox/rhythmdb.xml . It's probably corrupted and keeping Rhythmbox from starting. It will be recreated automatically, you will only lose some data like song ratings (data not included in file metadata, mainly). You will not lose your playlists. Give Rhythmbox a few seconds to start scenning music folders and repopulate the database.

2
  • it did not have any effect on 64 bit Ubuntu 14.04. if i start the player in terminal with the command rhythmbox, i get the error (rhythmbox:31511): Rhythmbox-CRITICAL **: Timeout was reached after around 10 secs. – faizal Aug 29 '14 at 2:52
  • it started after i did pkill rhythmbox. the db also looks good now, which was really messed up earlier with songs skipping randomly. thanks – faizal Aug 29 '14 at 2:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.