After upgrading to 13.10 from 13.04 the notebook screen is deadly black as the X server starts; the only workaround I found is to start with an external monitor connected. Doing this way I can login in and once I set the mirroring desktop I can normally operate on the external monitor.

The strange thing is that if I use xrandr to set the brightness to the maximum on LVDS I can see a little bit the images on the screen: but just a really little bit!!

I guess it's related to the AMD-driver catalyst version 13.20.16 beta 1 (fglrx), the only I can use with the new kernerl 3.11. (I tried even with other version of fglrx: the last stable on the amd-site, and the one provided in ubuntu-repository; but nothing changes)

My graphic adapter is an ATI Mobility Radeon 5XXX and if I try to not use ATI proprietary driver I can see correctly both screens but the system become very slow and all the interface is unstable (compiz doesn't load, cairo-dock doesnt' start, and so on...)

Please let me know what kind of more depth infos I could provide: I cannot find how to attach some file/log to this post...

Thanks in advance for your piece of advices!

  • I had a similar issue but with a different graphics card. The issue turned out to be screen rotation. I had two external monitors hanging off a Dell E5420 in rotated orientation. Apparently the rotation feature doesn't work very well. Everything looked and worked okay, until I logged off. The next login gave me the blank screen with just the mouse pointer. Unfortunately you can't fix the rotation if you only have a blank screen. I had to drop down to just the native screen to remove the rotation, but that gave me back my unrotated screens. – atikat Apr 2 '14 at 0:29

There isn't much solution at the moment because the open source drivers shipping with Ubuntu are essentially broken, and the Oibaf PPA which provides the latest 'Updated and Optimized Open Source Drivers' which would be perfect for your GPU only supports up to Ubuntu 13.04 still. Many people are having issues, but there's just little solution.

You can at least try using open source drivers and running sudo apt-get install xserver-xorg-video-all to make sure you have the open source drivers properly installed.

  • Ok! I have a try with the open-source! Thanks a lot! – James83 Oct 22 '13 at 10:44
  • oibaf just added support so Saucy not long ago, so now is the time to add it. – mmstick Oct 22 '13 at 12:01
  • mmstick, you're right! It did the trick: installing the ppa and removing fglrx, then resetting some permissions I finally get back my desktop with compiz and cairo-dock and 3d/GL support!!! Thanks a lot!! – James83 Oct 23 '13 at 10:05

I'm seeing this same thing on Fedora 19 with kernel 3.11.6-201 and Catalyst (fglrx) 13.9-2 and gnome-shell 3.8.4-2. I've seen it since one of the 13.8 beta versions I think.

Uninstalling the AMD drivers and using the open source Radeon drivers fixed the problem for me, but I had to give up hardware acceleration.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.