2

I have a problem in UbuntuGNOME 13.10 which I didn't had in prior releases: I did a clean install and I don't know if it was already there or if I may have changed something, but my "Control L" and "Caps Lock" keys are swapped. How to swap them back? See also the attached image.

http://i.imgur.com/PR1YB4T.jpg

I swapped them back using the following, but this is obviously not a proper fix:

$ cd ~
$ echo "keycode  66 = Control_L NoSymbol Control_L
remove Lock = Caps_Lock
remove Control = Control_L
keysym Control_L = Caps_Lock
keysym Caps_Lock = Control_L
add Lock = Caps_Lock
add Control = Control_L" >> .Xmodmap
$ xmodmap .Xmodmap

but the "Keyboard Layout Chart" program shows the keys still swapped. What's the reason for this? How to fix?

2

It doesn't look like the Keyboard Layout Options dialog is going to come back. You can swap the caps-lock and control keys in gnome-tweak-tool, under "Typing."

Screenshot:

gnome-tweak-tool

| improve this answer | |
  • Thanks. Reading this I thought it would work, but it doesn't :\ Really wired. (.Xmodmap was renamed of course) Are you using 13.10? – linuxubuntu Oct 25 '13 at 7:56
  • It works if I set it to "At bottom left" (and the keys are swapped i.imgur.com/fWqRH2W.png) :) This whole thing on 13.10 is buggy but since my problem is solved -- even if not properly(?) -- I set this question to answered. – linuxubuntu Oct 25 '13 at 8:23
0

I don't know how you did, but here is the reason:

In the Layout Preferences, there is an Option button, it should open a window like this:

enter image description here

As you can see, the subtree under "Ctrl key position" has an option to swap Ctrl and Caps Lock. When I activate it this is how looks my preview:

enter image description here

Desactivating the option brings everything to normal.

| improve this answer | |
  • Thanks. It seems there is a bug in UbuntuGNOME 13.10 where this dialog is not available :\ askubuntu.com/questions/360320/… – linuxubuntu Oct 22 '13 at 16:23
  • Ok, well, when the bug is solved at least you know how to solve it ;) Is the same path, look for "Options..." then the option in the screenshots. – Braiam Oct 22 '13 at 16:44
  • There's also nothing with "Options...". So there's no way to open "Keyboard Layout Options" somehow? – linuxubuntu Oct 22 '13 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.