2

I made the upgrade on my Lubuntu machine to 13.10 yesterday. Everything seemed to go smoothly except one niggling thing I can't seem to fix. Previously, I had set the power button to suspend my computer when it was pressed- I was able to set this in the Xfce Power manager.

However after the upgrade, pressing the power button will shutdown the computer rather than suspending. I did a test and checked the logs and found this when I pressed the power button:

auth.log:Oct 21 22:48:35 Inspiron-1564 systemd-logind[748]: Power key pressed.
auth.log:Oct 21 22:48:35 Inspiron-1564 systemd-logind[748]: Powering Off...
auth.log:Oct 21 22:48:35 Inspiron-1564 systemd-logind[748]: System is powering down.

I'm stuck here. Somehow systemd-logind thinks I want to shut the computer down, but I'm not sure where those settings may be. Any help is greatly appreciated.

Additionally, while this post has an answer that has a roundabout method of solving the problem, I will not accept that as an answer because it essentially doesn't work, and is not how the problem should be solved.

1 Answer 1

4

It seems that systemd-logind is in conflict with xfce4-power-manager. This seems to resolve it for me with xubuntu on and Inspiron 9400.

  • Tell systemd-logind to ignore the power button. Open a terminal with Ctrl+Alt+t. And enter the following command to edit the file:

    gksu leafpad /etc/systemd/logind.conf

Un-comment the line for HandlePowerKey and change the value from poweroff to ignore so that it looks like this:

HandlePowerKey=ignore
  • Restart the service

    sudo service systemd-logind restart

  • Use xfce4-power-manager-settings to set the power button action

Good Luck!

1
  • 1
    fantastic! The answer was right under my nose. I'll report this to the Lubuntu devs.
    – Dennis
    Commented Oct 30, 2013 at 16:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .