16

I previously installed Xubuntu 13.04 on my Compaq nx8420 and was able to use Bluetooth with no issues.

I recently performed a clean install of Ubuntu 13.10 (not Xubuntu), and now can't enable bluetooth. I go to the default Bluetooth app, move the slider to 'On' and it slides straight back to 'Off'.

Do I need to install any extra packages or use an alternative app to get Bluetooth working? I can't think of a reason why it would work in Xubuntu 13.04, but not Ubuntu 13.10.

  • Ok, So I installed the Bluez Bluetooth Stack from the Software Centre. This didn't fix my problem (not sure if this is required for Bluetooth to work on Ubuntu, or if its unnecessary and should be removed?). Then I installed the Blueman Bluetooth Manager and everything is working fine. The default obviously has some bugs I'm guessing. – cazzzac Oct 21 '13 at 23:49
  • 1
    Thanks for your help guys. Bluetooth is now working. But I'm now affected by a bug that makes the Wedge Mouse periodically disconnect. Ahh the joys of the newbie Linux user :) bugs.launchpad.net/ubuntu/+source/bluez/+bug/1094744 – cazzzac Oct 27 '13 at 4:06
  • 1
    For those who would like to have Bluetooth turned on at start-up, open Startup Applications, click Add and in Command field add: rfkill unblock bluetooth – HostX Dec 21 '13 at 23:30
16

try sudo rfkill unblock bluetooth and you will be fine!

  • This is going to work if the problem is that the bluetooth signal is turned off. In some cases, though, the problem is a lack of installed packages or bad settings in which case the other suggestions here may be necessary. Note that the op had to install the packages suggested by NKV here. So for him the problem was not that bluetooth was blocked. – monotasker Apr 18 '15 at 16:03
9

Theses steps solved the problem for me:

  • Open terminal
  • sudo rfkill unblock bluetooth
  • sudo gedit /etc/bluetooth/main.conf
  • Change the value of RememberPowered from true to false
  • Save the document

I found that WhiteFang's answer worked immediately. And I could see my bluetooth device with hcitool dev

But I also added dupont's solution: cannot connect my bluetooth speakers. why?

I used Alberto Alonso Ruibal solution but am not sure if it worked.

4

I had a similar problem upgrading from 12.10 to 13.10 and I solved it adding my user to the "bluetooth" group:

sudo usermod -a -G bluetooth $USER

You may need to put an actual username instead of $USER if the user having this problem is not the username you're logged in on.

  • 2
    You could instead use $USER if they are trying to do this as their user that they have this issue on, $USER should automatically become whatever their username is. – Thomas Ward Oct 25 '13 at 5:40
  • Awesome. I did add an additional blurb at the end to explain that if they aren't logged in as the affected user when running it, they'll have to replace $USER with an actual username, but all bases are covered here, now. :) – Thomas Ward Oct 25 '13 at 5:45
  • Can someone please confirm whether this fixes the issue permanently? Comment #43 and #44 in this bug report suggests that the fix only lasts until the next reboot. Thanks. bugs.launchpad.net/ubuntu/+source/linux/+bug/1242272 – Andreas J. Nov 5 '13 at 3:43
4

This worked for me

sudo hciconfig hci0 reset

Source : https://askubuntu.com/a/204427/69743

Running Gnome-Ubuntu 13.10

  • It gives me : Can't init device hci0: Operation not supported (95) – Menai Ala Eddine Sep 28 '18 at 21:49
  • @MenaiAlaEddine, Tell me output for rfkill list command – Gaurav Gandhi Sep 29 '18 at 7:24
  • I have Ubuntu 18.04 LTS.The output of that command is : ` :~$ rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: hci0: Bluetooth Soft blocked: no Hard blocked: no` – Menai Ala Eddine Sep 29 '18 at 9:54
3

The problem should be solved by running this command:

sudo apt-get install bluetooth blueman bluez-hcidump bluewho python-bluez  bluez-tools

Make sure you do not have gnome-bluetooth installed. gnome-bluetooth and bluez do not work together. Use either one of these, but not both.

For me bluez worked well. See if this works for you.

  • 5
    Removing gnome-bluetooth might break the system, because it automatically uninstalls many unity/gnome packages – Ed Villegas Oct 25 '13 at 19:55
  • @NKV Both gnome-bluetooth and bluez were installed by default on my fresh install of 13.10. Are you sure they cannot co-exist? – Andreas J. Nov 5 '13 at 3:14
  • @AndreasJonsson : yes, for me that created the problem and the problem was solved once I removed gnome-bluetooth. There is more literature on net for their inter-op problems. Try uninstalling it. You can always reinstall it back if problem is still not solved. – NKV Nov 15 '13 at 4:46
  • FWIW, my install of Ubuntu Gnome 14.10 didn't have gnome-bluetooth installed. So maybe it has been dropped from the default's? I just installed the packages recommended by NKV and had no conflicts. This also succeeded in getting my bluetooth working. – monotasker Apr 18 '15 at 16:05
0

Mac Mini mid-2010 (Macmini4,1) Bluetooth stopped working when upgraded from 13.04 (Raring) to 13.10 (Saucy).

Err Hunter suggestion worked for me

sudo hciconfig hci0 reset

protected by Community Dec 22 '13 at 1:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.