I've installed Ubuntu 13.10 on a Lenovo yoga 13. In order to make the backlight work with the keys I've been following some instructions of this answer (link edited)

The process I followed was this:

1) sudo gedit /etc/default/grub (generates errors, I think they are irrelevant - have checked in vim the edit worked)

2) sudo update-grub

3) blacklisted the ideapad_laptop by adding "blacklist ideapad_laptop" to /etc/modprobe.d/blacklist.conf file

Step 2) generates error: /usr/sbin/grub-mkconfig: 27: /etc/default/grub: want: not found

Answers from the comments

  • cat /etc/default/grub does show contents of the file

  • fgrep want /etc/default/grub gives: # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

  • sudo cat /etc/default/grub also shows contents of the file


The grub error from step 2 occurs whenever I try to install anything. I have previously tried to run the command sudo apt-get install grub-pc - which also generates this error. I'm worried I've upset the balance of my computer's universe...

  • 1
    Does cat /etc/default/grub show the content of that grub-file?
    – user85164
    Oct 21, 2013 at 21:59
  • 2
    Please attach the output of fgrep want /etc/default/grub to your question.
    – zwets
    Oct 21, 2013 at 21:59
  • Which of them? There are 4 answers.
    – Braiam
    Oct 21, 2013 at 22:01
  • perhaps newbish of me ?: sudo apt-get install --reinstall grub - or - sudo apt-get install --reinstall grub2 ? ( I wonder why to do update-grub for backlight ? - there is command xbacklight in terminal and for this after adjusted with this command the backlight only reboot is necessary - but not update-grub ? ) Oct 21, 2013 at 22:23
  • The output from the fgrep command is:# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux and cat /etc/default/grub does show the content
    – Jim
    Oct 22, 2013 at 22:53

1 Answer 1


Ok, so that was me being an idiot

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

was missing the quote mark off the end of it - must have made a mistake while editing the file. All sorted now, and the back light is working from the keys.

thanks @braiam for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.