I've installed Skype and it appears to work fine right up until the point where I try to call someone. If I try to video call someone then the program freezes and I have to force quit. I've tried several 'solutions' I've found on various forums but none seem to work. Now, when I try to call the Echo service as a test to see if the bug's fixed, it seems to connect and start the non-video call, except that it's completely silent. No audio at all.


This should make a permanent change for the workaround:

sudo sed -i 's/^Exec=.*/Exec=env PULSE_LATENCY_MSEC=30 skype %U/' /usr/share/applications/skype.desktop

Thanks go here

If you are using KDE:

Another non-terminal way is to to right-click on start button and select "Edit applications...":

enter image description here

NOTE: If you are using KDE session restoring (System Settings -> Startup and Shutdown -> Session Management -> On login: Restore previous session) then after system restart (or login) Skype will not catch PULSE_LATENCY_MSEC environment variable until you restart it via its .desktop file.


Got the same issue after upgrade to Ubuntu 13.10 sound interrupts badly. But suggesting to reinstall from Software Centre or from Skype download page did not help.

But running this from command line solved the problem:

Exec=/usr/bin/env PULSE_LATENCY_MSEC=30 /usr/bin/skype
  • This fixed it for me, thanks! Anyone able to explain why this works? – Kibi Oct 23 '13 at 7:53
  • Is there any way that this could be made to work from the unity launcher? – hookd Oct 27 '13 at 18:49
  • It works on Linux Mint 16 too! – Adam Ryczkowski Dec 2 '13 at 17:30
  • Reinstalling Skype from Canonical Partner repos did not help you if you start Skype via anything that bypasses the (patched) skype.desktop file. For example, starting via the Alt+F2 mini-terminal. To apply your solution there also, create an executable file /usr/local/bin/skype with first line #!/bin/bash and next line env PULSE_LATENCY_MSEC=30 /usr/bin/skype – tanius Feb 19 '14 at 1:08

I found this solution for Skype on 13.10. I installed again and started to work. Check it out: http://www.webupd8.org/2013/10/get-sound-working-in-skype-with-ubuntu.html

  • 2
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – RolandiXor Dec 16 '13 at 19:44
  • Same as answer by @warwaruk. – tanius Feb 19 '14 at 1:11

protected by Braiam Feb 23 '14 at 23:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.