Since I updated to Lubuntu 13.10 (64 bit) as upgrade from 13.04, my laptop screen is black. My external monitor over HDMI works. I have an AMD ATI Radeon HD 5470 card.

The laptop screen starts ok, I see Grub, the Lubuntu start with dots and when the lightdm GUI should start, it the laptop screen turns black. At the same time the external monitor (HDMI) starts showing the GUI.

I have a dual boot system with Windows and in Windows it works ok. The Fn+brightness keys work also on Lubuntu - I see the brightness indicator at 100% in the Lubuntu external monitor.

I tried fglrx, the latest amd proprietary beta driver, and have currently fglrx-updates. Same result with all.

In amdcccle panel the LVDS looks ok. I can enable / disable it, configure it, etc, but it just remains black. It does not seem to be directly an a config issue, as same config used to work in 13.04.

I have been looking at the forums since two days and trying various stuff, without any result.

May be someone has a clue for me.

Some more information:

$ dpkg -l fglrx* Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name
Version Architecture Description +++-==============-============-============-================================= un fglrx-amdcccle (no description available) ii fglrx-amdcccle 2:13.101-0ub amd64 Catalyst Control Center for the A un fglrx-control
(no description available) un fglrx-control-
(no description available) un fglrx-driver
(no description available) un fglrx-glx
(no description available) ii fglrx-updates 2:13.101-0ub amd64
Video driver for the AMD graphics

$ lspci | grep -i vga 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470]

$ fglrxinfo display: :0 screen: 0 OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: ATI Mobility Radeon HD 5400 Series OpenGL version string: 4.2.12337 Compatibility Profile Context 13.101


Section "ServerLayout" Identifier "aticonfig Layout" Screen
0 "aticonfig-Screen[0]-0" 0 0 EndSection

Section "Module" EndSection

Section "Monitor" Identifier "aticonfig-Monitor[0]-0" Option
"VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection

Section "Monitor" Identifier "0-LVDS" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" Option "TargetRefresh" "60" Option "Position" "1920 312" Option "Rotate" "normal" Option "Disable" "true" EndSection

Section "Monitor" Identifier "0-DFP1" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" Option "PreferredMode" "1920x1080" Option "TargetRefresh" "60" Option "Position" "0 0" Option "Rotate" "normal" Option "Disable" "false" EndSection

Section "Device" Identifier "aticonfig-Device[0]-0" Driver
"fglrx" Option "Monitor-LVDS" "0-LVDS" Option "Monitor-DFP1" "0-DFP1" BusID "PCI:1:0:0" EndSection

Section "Screen" Identifier "aticonfig-Screen[0]-0" Device
"aticonfig-Device[0]-0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection

  • Are you able to reproduce this?
    – Braiam
    Feb 22, 2014 at 22:02

1 Answer 1


Ok, I finally fixed this by removing the closed-source proprietary driver, and using the open source Radeon driver. See https://help.ubuntu.com/community/RadeonDriver

The open source driver fully supports my ATI card CEDAR Radeon HD 5430/5450/6330/6350/6370

To install the open source driver it is enough to fully remove the closed-source one (more details at https://wiki.ubuntu.com/X/Troubleshooting/VideoDriverDetection#Problem:_Need_to_purge_-fglrx). This is what I used:

sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
sudo shutdown -r now

After restart both laptop screen and my external monitor screen worked. To set the resolution for the two monitors I used arandr tool.

To check all is ok:

sudo lshw -c video

should show ... configuration: driver=radeon latency=0

Hope this will be of help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .