0

I have just installed Ubuntu 13.10 (special iMac iso found here) on the new iMac (dual boot). Installation of rEFIt was completed successfully, as well as the installation of Ubuntu itself.

After the final reboot, rEFIt sees this distributive and allows the choice. When I select "Boot linux from HD", it sends me to grub screen, where I can select Ubuntu. And then it gets stuck on the purple screen (smpboot: Booting Node 0, Processors #1 -- for the recovery mode) with no further action. Does anybody know a solution to this problem?

P.S.: I have also tried both 32 and 64-bit pc distributives (occasionally) with the same result.

  • Try with acpi=off or nomodeset – pratnala Oct 21 '13 at 18:00
  • Thank you for your comment! Could you please indicate where shall I use this configuration, as I've never seen it before. – Eugene B Oct 21 '13 at 18:19
  • I have managed to try this. It results to the same thing again. – Eugene B Oct 22 '13 at 10:39
  • Both give the same result? Try nomodeset with noapic or nolapic – pratnala Oct 22 '13 at 10:47
  • I have tried it again, and it worked with acpi=off! Could you please write as an answer, so that I could accept that? – Eugene B Oct 22 '13 at 12:10
1

Ubuntu has some compatibility issues running on Macs (some ACPI issues, I believe). Using the acpi=off or nomodeset or noapic or nolapic or a combination of one or more of these can help you boot normally.

I have a MacBook Pro too and used the noapic and nomodeset flags until 12.10. From 13.04 onwards, I am not using any flags.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.