Ever since i started using Xubuntu I have noticed that whenever I run any heavy application like Eclipse, Tomcat Server or even when I open sites like facebook in multiple tabs in the Web Browser my system begins to lag. Even the mouse movement and Keyboard input are affected by it hence I am unable to open Virtual Console to close the application. The only way to get rid of it is to wait for 15 to 20 min or to reboot the system using REISUB. I tried using applications like Preload but even that didn't help.

I have not allocated any swap space but the memory usage of the system rarely crosses 2 GB. Even when the heavy applications were running, still more than 1 GB of the RAM was free. My laptop has 4 GB RAM and 2.13 GHz processor. Xubuntu version is 13.04 and i update my system regularly. Earlier i have used other distributions like OpenSuse but they all ran smoothly on my laptop. Even windows runs without any issue.

Is the swap space the problem or are there any logs i should check ? The dmesg and the kern.log don't show any abnormal behavior. Is there a way to change scheduling method which it uses or to lower priorities of applications so that they don't affect other applications ?

  • Swap space should never be a problem. Seems odd though, I brought a new laptop, with 2 GB RAM and a celeron processor and the mouse movement is not choppy even while rendering 1080p videos in openshot or kdenlive. Seems to be a problem with your graphics card drivers. Are you using Nouveau or proprietary drivers? Check your .xsession-errors and Xorg.0.log.
    – simbadub23
    Oct 21, 2013 at 16:31
  • I am using proprietary AMD Drivers as the open source ones drained too much battery. I haven't checked the X logs. There are too many messages in them so i am unable to make out what the problem was. Should i paste them somewhere ?
    – adityap174
    Oct 21, 2013 at 16:41
  • It didn't occur to me that the problem could be with the graphic drivers so I didn't bother to check them. But the system lags only when I open specific sites like Facebook.
    – adityap174
    Oct 21, 2013 at 16:42

1 Answer 1


If anyone else is facing the same problem, the problem was the swap space. When I worked on JSP, Tomcat server alone took up around 400 MB memory space. Eclipse and the Browser took up the rest. I created a swap file in my root directory using:

sudo fallocate -l 2048m /mnt/2048MiB.swap 

and added it to the fstab after mkswap and swapon commands. Now it works properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.