I think it's a bug. But I can't seem to find any information about it. The mouse pointer hides itself, but it is still possible to use it.

Whenever I start watching a video in VLC, or start playing KSP through Steam my mouse pointer disappears. But it's not returned upon exiting the application. I have not tried with other games in Steam. The mouse pointer does not disappear when watching videos online through YouTube at first, but it properly hides itself after a few seconds.

The bug came about after I updated to 13.10, it was not present with the same setup in 13.04. I've tried removing ~/.compiz and restarting the kernel module psmouse.

Going to tty1 and back to the desktop reveals the pointer, though this fix is bothering me.

How do I fix this problem?


FYI, doug's response here seems to have solved the problem for me. Several hours now with no issue. Using Synergy heavily as well, which was always a sure way to make it vanish.

The gist: gsettings set org.gnome.settings-daemon.plugins.cursor active false

  • After switching from Unity to Gnome Shell in 13.10 and then doing a dist-upgrade, I also got the invisible mouse, and this line fixed it. Just open up a terminal (Ctrl+Alt+t should be it) and then punch in that line. The cursor immediately appeared. Thanks! – Taylor Alexander Jan 15 '14 at 20:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.