0

After upgrading my Ubuntu to the newest version 13.10, in the login interface, my account does not appear. I can login the guest session. There is also a remote login. I have no place to input my username to login my account. Does anyone have the same problem?

----EDIT----

Here is the file lightdm.conf

[SeatDefaults]

greeter-session=unity-greeter

user-session=ubuntu

----EDIT TWO---

Here is the official bug report:

https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1235785

6
  • Can you give us the content of /etc/lightdm/lightdm.conf and add it to your question?
    – MadMike
    Oct 21, 2013 at 15:18
  • Sure, MadMike, I have updated my post. Thanks a lot!
    – Anand
    Oct 21, 2013 at 15:23
  • @Anand Can you login in tty1? Oct 21, 2013 at 15:30
  • yes, i can login in tty1 with either my username or root.
    – Anand
    Oct 21, 2013 at 15:32
  • What is your numeric user ID? By default, the greeter will not show your user entry if your UID is less than 500. Type 'id' at a shell prompt to see your UID.
    – Mox
    Oct 22, 2013 at 19:33

2 Answers 2

1

Found the solution that worked for me. Because I had installed likewise-open it had told lightdm to hide local users.

open the following file from command line:

sudo nano /etc/lightdm/lightdm.conf

In the [SeatDefaults] section, there's a line that should say the following:

greeter-hide-users=false

(mine had gotten changed to true, so all local users weren't being displayed. Rebooted after than and I can see my local users again.

0

Problem partially solved by login in the tty1 as root and run:

 /usr/lib/lightdm/lightdm/lightdm-set-defaults --autologin=USERNAME

and then

reboot

See also:

https://wiki.archlinux.org/index.php/LightDM

Now after reboot, I am in my account. But if I log out, my account still does not appear in the list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.