8

Setup

I have a fresh install of Ubuntu 13.10, with KDE (installed via Ubuntu server disk and sudo apt-get install kubuntu-desktop).

Problem

Whenever I suspend the computer while in KDE (either via sudo pm-suspend in Konsole or via KDE's interface), I get a black screen on wake up.

Attempted workarounds / fixes

If I press ctrl+alt+f1 and then ctrl+alt+f7 and I'm patient (20-30 seconds), I sometimes get back into KDE where I was, or sometimes I get back to the login screen (KDE crashed). But even when I get back into KDE, I get a notification saying that the special effects had to restart due to a graphics problem and then the fonts in all applications are... garbled.

If I suspend from another tty with sudo pm-suspend (while KDE is running on tty7), it works flawlessly (resumes instantly - no need to wait 20-30 seconds, KDE does not crash and does not cause font garble).

I tried changing graphics drivers and I get the same thing (I have Nvidia NVS300 and I'm using the latest proprietary drivers in Ubuntu repos). Also tried this Ubuntu freezes/crash after wake when upgraded to 13.10 and it didn't work.

This problem did not occur on the same system, when I was running Kubuntu 12.04.

Trying to find the problem...

Dmesg doesn't show any errors. I don't even know where to look further for any errors (any KDE logs?). Any help appreciated.

  • I'm having similar problems with hibernate but not suspend. Do you also see this in hibernate? – virtualxtc Dec 18 '13 at 0:59
  • Also, have you verified hibernate is active in your BIOS? I never remember the BIOS terminologies my self, so you might find this page helpful: gsmblog.com/post/… – virtualxtc Dec 18 '13 at 1:11
  • @virtualxtc When I try to hibernate, the screen goes black but it doesn't go into hibernate (power lights don't go off and fans still spinning). But computer remains unresponsive. Looking in /var/log/pm-suspend.log (after I power cycle the computer), I see that it reports that it thaws back a few seconds after the hibernate command. – Vlad A Ionescu Dec 18 '13 at 10:43
  • @virtualxtc My BIOS doesn't have a setting for enabling / disabling standby modes. – Vlad A Ionescu Dec 18 '13 at 10:45
  • hum, if the solutions below don't suit your likeing you might want to play with the grub2 powermangement boot flags (acpi=on, acpi=off) more here: help.ubuntu.com/community/BootOptions – virtualxtc Dec 18 '13 at 12:05
5

I found this workaround. I made a script that switches to console before suspend and switches back after resume.

I put attached script into dir /etc/pm/sleep.d. I gave it the name fix-black-screen and made it executable (sudo chmod +x /etc/pm/sleep.d/fix-black-screen).

#!/bin/bash

case $1 in
suspend)
    # Suspending to RAM.
    chvt 1
    sleep 1
;;
resume)
    # Resume from suspend.
    sleep 1
    chvt 7
;;
esac

Original fix found here.

2

I had similar problems to yours.

pm-suspend --store-quirks-as-lkw

Fixed my problems.

I only had to do it once, and suspending after that was working fine.

Give it a try.

  • Thanks for the answer, Pedro. It didn't help unfortunately. I get the same behaviour as before. – Vlad A Ionescu Oct 27 '13 at 17:15
0

I also have a machine with the latest nvidia driver and was seeing the same issue. I found that

pm-suspend --quirk-save-pci

seems to have solved the problem. I put it in my /var/cache/pm-utils/last_known_working.quirkdb file and I think it's working now.

Not the answer you're looking for? Browse other questions tagged or ask your own question.