3

I have a Dell Studio 1558. When I originally installed 13.04 on it, I had to modify my /etc/default/grub with the following:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor dell_laptop.backlight=0 quiet splash"

Doing that made everything work, the keyboard brightness buttons, the OSD in the top right corner, and the brightness slider in System Settings. However, upon upgrading to 13.10, I once again am unable to adjust the backlight. This is also the case if I use either of the following:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor quiet splash"  
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  

The backlight is stuck at a single brightness level, at a guess I think it's somewhere around 50%. The OSD still comes up if I push the keyboard buttons, but the bar only goes down one division from 100% and resets back to 100%, if I press decrease again. The slider in 'System Settings' does nothing.

Any help is greatly appreciated!

3

Doing both of the steps mentioned here fixed this issue with a Dell Studio 1558 and Ubuntu 13.10: http://ubuntuforums.org/showthread.php?t=2181534

Change /etc/default/grub

I used "sudo vim /etc/default/grub" but use whatever editor you're comfortable with but you will need to use sudo to edit it as the root user.

From:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

To:

GRUB_CMDLINE_LINUX=""

Then run:

sudo update-grub

Add /usr/share/X11/xorg.conf.d/20-intel.conf

I used "sudo vim /usr/share/X11/xorg.conf.d/20-intel.conf" and then ran :set paste and hit i for insert and pasted in the contents.

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection

Then reboot and login again and your function key with the brightness up/down should work again.

4

Try this in a terminal:

echo 4000 | sudo tee /sys/class/backlight/intel_backlight/brightness

4000 is the full brightness, and 0 is no brightness (screen completely dark), so you can choose any value in between as you like. Note that the path to the brigtness may be different on your computer, so adjust accordingly.

This works for me on Dell Studio 1558, Ubuntu 13.10 64 bit. Also you'll have to do this every-time you have to change brightness. It will reset when you restart the computer.

Good luck!

  • Thanks, this worked like a charm as a workaround. I even setup keyboard shortcuts to invoke a bash script give me keyboard control. – TheSchwa Aug 8 '14 at 2:10
  • Good to know :) Your eyes will thank you! – rgamber Aug 8 '14 at 6:43
  • can you please tell me how to use echo 4000 | sudo tee /sys/class/backlight/intel_backlight/brightness because its giving me error like no file or directory found. Please help. – user612652 Oct 28 '16 at 18:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.