Internet works perfectly on host (Ubuntu 13.04, 32 bit, fully updated) but cannot connect to internet on guest Windows 7 (under Virtualbox 4.2). Have tried NAT and Bridge Network - none worked. I had internet connection in the guest OS a couple of months ago, but I haven't tried the virtualbox since and now it's gone for some reason. I would be grateful if someone could help me re-connect the windows OS back online (without the need to format my computer or to uninstall and re-install the guest OS). Thanks!

  • 1
    Should be a misconfiguration in Windows.
    – Naveen
    Oct 21, 2013 at 12:44
  • 1
    Any thoughts on how to fix this?
    – Ben
    Oct 21, 2013 at 16:44
  • 2
    You can try to boot the guest using a Live CD, if it has internet connection it is a Windows issue, if it doesn't then it's likely a VB configuration issue. Oct 22, 2013 at 6:44
  • This also happens in ubuntu 20.04, with host windows 7, 8, 10. It only happens with the wifi card in bridge adapter mode (selecting wifi). It does not happen in NAT, or otherwise. It also does not happen with ethernet cable. It happened to me and the solutions I found were: change the network (wifi point), or change the wifi card
    – acgbox
    Oct 31, 2021 at 16:40

7 Answers 7


I was having the same problem on Ubuntu 12.10 64bit using Virtualbox 4.2.22. Here are the steps I took to solve my problem:

  1. Open Virtualbox Manager
  2. Select the machine you cannot get internet on in the left pane
  3. Click the Settings button in the top menu
  4. Click Network in the left pane in the settings window
  5. Switched to Bridged Adapter in the Attached to drop-down menu
  6. Select the name of the network adapter you are currently using on your host machine. I am using wireless so I chose eth0 which is my wireless network adapter. You can check which adapter you are currently using by opening the terminal (CTRL+ALT+T by default) and running ifconfig. It will probably be the eth adapter that shows an inet addr and shows data transfer next to RX bytes.
  7. Under Advanced, make sure the machine is using the Desktop Adapter Type
  8. Under Advanced, make sure Promiscuous Mode is set to Allow All
  9. Under Advanced, make sure Cable connected is checked on
  10. Hit OK to save your changes
  11. Start your VM

At that point you should be able to start a web browser in your VM and get a connection. This video provided the information I listed above, even though they are using a Windows 7 host with a Windows Server guest.

This is an image showing an example of the settings you need (taken from this answer).

Virtualbox Network Settings

  • 15
    Still, problem remains the same.
    – Mansuu....
    Jun 14, 2017 at 9:48
  • 1
    This worked for my VM ubuntu 14.4 on windows 10 host machine. Thank you Jake.
    – Uday
    Dec 29, 2017 at 15:00
  • Worked for me. I input the MAC address of my host machine's network adapter in the Mac Address field of the guests's network configuration dialog. Feb 1, 2019 at 9:37
  • Worked for me for connection through iphone. Host: MacOS, guest Ubuntu (guest should be irrelevant I believe). Thanks a lot! Feb 1, 2019 at 9:49
  • 1
    Worked for me on my Ubuntu Server 16.04 guest on Ubuntu Desktop 16.04 host. Thanks. Jun 4, 2019 at 5:47

This solution worked for me:

vi /etc/sysconfig/network-script/ifcfg-enp0s3

Then change

ONBOOT = yes

Then reboot.

  • You realize that you propose to change settings in the host OS while the problem exists in the guest?
    – guntbert
    Nov 10, 2016 at 18:58
  • (Also having a Adapter 1 with "NAT"), Note I also has another Adapter 2 with "host-only" but it is for connecting host and guest (ping from both). Thanks! Jan 4, 2017 at 3:02
  • Worked good for me. No idea why it did not turn on as default, but well, well...
    – patrik
    May 8, 2019 at 13:17

If it was working fine until recently, but suddenly your VM seems to have lost network connectivity while the host seems to have normal internet connection, then maybe just try the following steps.

Step 1: Right click on the network icon for the VM, Which most of the time will be on the bottom right corner in windowed mode.

VirtualBox Networking stopped working

Step 2: Toggle off the button named "Connect Network Adapter" and after waiting for like 10 seconds toggle it back on.

Another solution: If you are on windows Host, Go to Control Panel\Network and Internet\Network Connections right click any of the Virtualbox adapter and select Diagnose, let it do its thing and if it finds some anomaly with the adapter it will give you a prompt to reset the adapter by Apply the recommended solution/changes , you opt in for that, after its done, you most probably should have the network back to normal in your virtual machine.

I have to do this step almost regularly since I rarely shutdown my PC and always put it to sleep so after waking up I frequently encounter this issue.

VirtualBox Networking stopped working suddenly

  • Perfect! you solved my problem.
    – Rakesh
    Jan 7, 2020 at 3:25

For wireless to work, in my machines anyway, the WiFi MAC address in Settings must match the hardware, and wlan0 must be selected (when host Internet comes through wireless).


After gaining much more experience with this, I find:

  1. The initial network connection is very finicky and inconsistent.
  2. Once made, it reconnects every time with no problem.
  3. The MAC address does not need to match the hardware (as initially stated).
  4. Because of 1., trouble with the VM Internet connection is best remedied by unbridging and/or changing the MAC, starting the VM, stopping, re-bridging, etc. Sooner or later, it will connect.


Here's a quick HowTo:

First click your network icon and select Connection Information.

On the Hardware Address line, copy the MAC address (the six digit-pairs separated by colons).

Paste in a neutral location such as a text editor, where the colons can be edited out (remove them). Copy the rendered 12 characters remaining.

Note: Attempts to paste the MAC with the colons still present will fail.

With the latest VirtualBox (VBox) available from *buntu repos, v4.1.12 at this writing:

In VBox, with the VM selected, click Settings. Click Network and on that page, typically under the Adapter 1 tab, click Advanced.

Click the dropdown at Attached to: and select Bridged Adapter. Highlight the 'Mac Address' data and delete it. Paste the true MAC address copied above.

Check parameters are set as follows, in order from top-to-bottom:

  • Enable Network Adapter: checked
  • Attached to: Bridged Adapter
  • Name: wlan0

Under 'Advanced'

  • Adapter Type: the one with "Desktop" in the name
  • Promiscuous Mode: Allow All
  • Mac Address: as copied and pasted above
  • Cable Connected: checked

Note that in the VM window, for Win7 at least, the WiFi symbol appears different from what it is in native mode. But WiFi is running nonetheless.


I tried above solutions but unfortunately i did not find working.

I tried below mentioned solution:

  1. set NAT Adapter in virtual box setting > Network settings.
  2. Add "BOOTPRO=DHCP" in network adapter.
  3. Check Allow internet sharing option in host machine adapter.

I had the same problem with a VirtualBox VM (5.9.14) that was working previously and stopped working after a shutdown/reboot. In my case the VB option "cable connected" got disabled for some obscure reason. Enabling that again made everything work again (no need for promiscuous mode in this case since I'm not doing anything requiring this - no WireShark or anything of that kind) Bottom line: do not assume that the Network configuration for your VM is correct. If you have problems, review that part of the configuration.

  • Also, for some reason, the network settings are best changed with the machine powered down, not just suspended or modified from the running machine menu. I've had this happening to me a few minutes ago and this answer inspired me to check the "master" network configuration. I sometimes had to change bridging from the ethernet to the wifi host interface, and I usually suspend the guest instead of powering it off; after a few switches, this must have made the kernel confused.
    – LSerni
    Oct 4, 2016 at 6:21

I ended up finding that my issue was in regards to my Network Center. Ensure that the wifi you are connected to is sharing internet, with the VirtualBox wifi adapter. This configuration is under the adapter settings in Network and Sharing Center.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .